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General Safety Summary  

Review the following safety precautions to avoid injury and prevent damage to 
the measurement instrument or any products connected to it. To avoid potential 
hazards, use the software and measurement instrument only as specified.  

While using this software, you may need to access other parts of the system. 
Read the General Safety Summary and specification sections in other equipment 
manuals for warnings, cautions, and ratings related to operating the system with 
this software.  

To avoid Fire and Personal Injury: 

Connect and Disconnect Properly. Connect the probe output to the 
measurement instrument before connecting the probe to the circuit under test. 
Disconnect the probe input and the probe ground from the circuit under test 
before disconnecting the probe from the measurement instrument. 

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all 
ratings and markings on the measurement instrument and other equipment used 
with this software. Consult the individual product manuals for further ratings 
information before making connections to the circuit under test.  

Do Not Operate With Suspected Failures. If you suspect there is damage to the 
measurement instrument or other equipment being used with this software, have 
it inspected by qualified service personnel.  

Symbols and Terms: The following terms and symbol(s) may appear in the 
manual. 

 WARNING. Warning statements identify conditions or practices that could 
result injury or loss of life. 

 

 CAUTION. Caution statements identify conditions or practices that could 
result in damage to this product or other property. 
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Introduction 

The TDSDVI is a Digital Visual Interface Compliance Test Solution that helps 
test, validation, and design engineers perform DVI physical layer validation and 
compliance testing. TDSDVI Test Solution is the first test solution to provide 
credible test results in conformance with the DVI specifications and the DVI Test 
and Measurement Guide. 

 

Figure 1: TDSDVI Application 

TDSDVI provides fully automatic testing with automatic oscilloscope setups, eye 
mask generation, and parametric testing for DVI compliance. 

The TDSDVI complies with the DVI specifications and:  

� Enables the DVI developers to test designs according to the test procedures 
in the DVI Test and Measurement Guide. 

� Offers automated tests for: 

� Transmitter: Eye Diagram, Pk-Pk Jitter, Intra-Pair Skew, Inter-Pair 
Skew, and Rise and Fall Time 

� Cable: High-Amplitude Eye Diagram, Low-Amplitude Eye Diagram, 
Pk-Pk Jitter, Intra-Pair Skew, and Inter-Pair Skew 

� Receiver: High-Amplitude Eye Diagram and Low-Amplitude Eye 
Diagram 

� Automatic "one-button" testing ensures faster validation with higher 
reliability. 

� Supports all resolutions up to UXGA. 

� Half Clock and Pseudo Random Patterns for various resolutions allow 
testing according to DDWG procedures. 
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Online Help and Related Documentation 
You can access the information on how to operate the application along with the 
oscilloscope through the following related documents and online help. 

Using Online Help 

Select Help on the right side of the oscilloscope menu bar to bring up the help 
file. 

Tables of Contents (TOC) tab — organizes the Help into book-like sections. 
Select a book icon to open a section; select any of the topics listed under the 
book. 

Index tab — enables you to scroll a list of alphabetical keywords. Select the 
topic of interest to bring up the appropriate help page. 

Find tab — allows a text-based search. Follow these steps: 

1. Type the word or phrase you want to find in the search box. 

2. Select some matching words in the next box to narrow your search. 

3. Choose a topic in the lower box, and then select the Display button. 

To print a topic, select the Print button from the Help Topics menu bar. 

Select Options from the menu bar for other commands, such as Refresh. 

Select the Back button to return to the previous help window. Use the Hyperlink 
to jump from one topic to another. If the Back button is grayed out or a jump is 
not available, choose the Help Topics button to return to the originating help 
folder. 

Sometimes you will see the word Note in the topic text. This indicates important 
information. 

Note: Certain aspects of the online help are unique to applications that run on 
the oscilloscope.   

Blue or green underlined text indicates a jump (hyperlink) to another topic. 
Select the underlined text to jump to the related topic.  Select the underlined text 
to jump to the related topic. For example, select the blue text to jump to the topic 
on Online Help and Related Documentation and the Back button to return to the 
topics page. 
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Tip You can tell when the cursor is over an active hyperlink (button, jump, 
or pop-up), because the cursor arrow changes to a small hand. 

Note: This graphic Tip identifies additional information that will help you 
use the application more efficiently. 

Printing from Online Help 

While using the TDSDVI online help, you can print topics and information from 
the Help viewer. Some online help topics have color in the examples of the 
displayed application. If you want to print this type of topic on a monochrome 
printer, some information may not print because of certain colors. Instead, you 
should print the topic from the PDF (portable document format) file that 
corresponds to the Online Help. You can find the file in the Documents directory 
on the Optional applications Software on Windows-Based Oscilloscopes  
DVD. The figures of application menus in the PDF file are gray scale so the 
relevant information will appear on the printed page. 

To print a single topic: 

1. Find the topic in the Contents pane. 

2. Click Print. 

3. Click Print the selected topic and click OK. 

To print all topics in a selected TOC book: 

1. Find the TOC book in the Contents pane. 

2. Click Print. 

3. Click Print the selected heading and all subtopics and click OK. 

Related Documentation 

� Oscilloscope Information: The user manual and user online help for your 
oscilloscope provides general information on how to operate the 
oscilloscope. 

� You can download PDF versions of many user manuals from the Tektronix 
Web site. 

� Programmer Information: The online programmer guide for your 
oscilloscope provides details on how to use GPIB commands to control the 
oscilloscope.  

You can download programmer information and examples from the Tektronix 
Web site. 
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Refer to the Optional Applications Software on Windows-Based Oscilloscopes 
Installation Manual for the following information: 

� Software warranty 

� Software license agreement 

� List of all available applications, compatible oscilloscopes, and relevant 
software and firmware version numbers 

� Applying a new label 

� Installing procedures  

� Enabling an application 

� Downloading updates from the Tektronix Web site 

You can find a PDF (portable document format) file for this document in the 
Documents directory on the Optional Applications Software on Windows-Based 
Oscilloscopes DVD. The CD booklet only contains information on installing the 
application from the CD and on how to apply a new label. 

Conventions 

This online help uses the following conventions: 

� Refers to the TDSDVI Compliance Test Solution as the TDSDVI or as the 
application or the software.  

� ESB refers to the Equivalent Source Board, HCP to Half Clock Pattern and 
PRP to Pseudo Random Pattern. 

� When steps require a sequence of selections using the application interface, 
the ">" symbol marks each transition between a menu and an option. For 
example, File> Minimize.  

� GP knob refers to the General Purpose Knob. 

� DUT refers to the device under test. This can be a Transmitter, Cable, or a 
Receiver device. 

� CRU is the Clock Recovery Unit. 

� In the application fields, you can use either the calculator keypad or the GP 
knob to enter the values. 

� PLL Clk or PLL Clock refers to the Phase Locked Loop Clock. 
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Feedback 

Tektronix values your feedback on our products. To help us serve you better, 
please send us your suggestions, ideas, or comments on your oscilloscope. 

Direct your feedback via e-mail to techsupport@tektronix.com or 
dvifeedback@tek.com or FAX at (503) 627-5695 and include the following 
information. Please be as specific as possible. 

General information:  

� Oscilloscope model number and hardware options, if any  

� Probes used  

� Your name, company, mailing address, phone number, FAX number 

� Please indicate if you would like to be contacted by Tektronix about your 
suggestion or comments  

Application specific information:  

� Software version number 

� Firmware version of the oscilloscope 

� Description of the problem such that technical support can duplicate the 
problem 

� If possible, save the oscilloscope and application setup files as .set or .ini 
files 

� If possible, save the waveform on which you are performing the 
measurement as a .wfm file 

Once you have gathered this information, you can contact technical support by 
phone or through e-mail. If using e-mail, be sure to enter in the subject line  
"TDSDVI Problem", and attach the .set, .ini and .wfm files.  

TDSDVI-DVI Compliance Test Solution           5 



Introduction 
 

 

 

 

6                                       TDSDVI-DVI Compliance Test Solution 



 

Getting Started 

Compatibility 
For information on oscilloscope Compatibility, refer to the Optional Applications 
Software on Windows-Based Oscilloscopes Installation Manual, Tektronix part 
number 077-0067-XX. The manual is also available as a PDF file. 

Requirements and Restrictions 
Do not change the oscilloscope settings when a test is running. If you change the 
settings, the application may give incorrect test results. 

Prerequisites 

� Read the Readme.txt file before you install the application. 

� TekVisa must be installed on the oscilloscope. If you do not have TekVisa, 
you can download it from www.tektronix.com. 

� The Sun Java Run-Time Environment V1.4.2 must be installed on the 
oscilloscope to operate the application. If Java Run-Time Environment is 
not installed, it will be automatically installed when you install the 
application. If you remove JRE v1.4.2, you can reinstall it by reinstalling the 
application. 

� If the signal is not connected and the noise level is below 50 mV, the 
application detects this and displays the message: "Improper Waveform". 

� To get appropriate results in Pk-Pk Jitter measurements, from the 
oscilloscope menu bar, select Measure> Waveform Histograms> Adjust 
Histogram Box Limits. 

For better and reliable results 

To calibrate (Signal Path Compensation) an oscilloscope, select Utilities> 
Instrument Calibration in the oscilloscope menu bar and select the Calibrate 
button. 
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Accessories 
The application supports the following differential probes: 

� P7350 

� P7330  

� P6330  

The application supports the following single-ended probes for skew testing:  

� P7240 

� P6249 

Other accessories 

� SMA Cable to connect recovered (PLL) clock from the TPA-R and TPA-P 
fixture 

� TCA-BNC adapter to use a P6330 probe 

� TCA-SMA adapter to use the SMA cables 

Updates from the Web site 
You can find information about this and other applications at the Tektronix Web 
site, www.tektronix.com. Check this site for application updates and other free 
applications. 

To install an application update, you will need to download it from the Tektronix 
Web site to the oscilloscope hard disk.  

Note: More information about changes to the application or installation is in a 
Readme.txt file on the Web site. You should read it before you continue. 
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Installation and Uninstallation Procedures 

Installing the Application 

Refer to the Optional Applications Software on Windows-Based Oscilloscopes 
Installation Manual for the following information: 

� Installing procedures  

� Applying a new label  

� Enabling an application 

� Downloading updates from the Tektronix Web site 

You can find a PDF (portable document format) file for this document in the 
Documents directory on the Optional Applications Software on Windows-Based 
Oscilloscopes DVD. The CD booklet contains information on how to install the 
application from the CD and on how to apply a new label. 

Uninstalling the Application 

To uninstall the application: 

1. On the Windows task bar, select Start> Settings. 

2. Select Control Panel> Add/Remove Programs. 

3. Select DVI Compliance Test Solution from the programs list. Select 
Add/Remove and the Installshield will take you through the uninstallation 
procedures. 
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Basic Application Functions 

Starting the Application 

Follow these steps to start the application: 

1. Depending on the type of oscilloscope, you can start the application in one 
of the following ways: 

� Select File> Run Application> DVI Compliance Test Solution from the 
oscilloscope menu bar. 

� Select Analyze> DVI Compliance Test Solution. 

2. A splash screen indicates that the software loading is in progress. 

3. The oscilloscope display resizes to fit the upper half of the screen and the 
lower half of the oscilloscope screen displays the TDSDVI application user 
interface. If you access the oscilloscope functions, the oscilloscope display 
appears in full screen and the TDSDVI application interface recedes to the 
background. 

Maximizing and Minimizing the Application Window  

The application appears even when you minimize the oscilloscope display. 

1. To minimize the application, select File> Minimize.  

2. To maximize the application, select TDSDVI application in the Windows 
toolbar.  

3. To hide the application, select the Hide button . 

Note: If you select Hide button, the TDSDVI application window minimizes to the 
Windows taskbar and the oscilloscope display resizes to the full screen. 

If you select File> Minimize, the application window minimizes to the Windows 
taskbar. The upper half of the screen shows the oscilloscope display and the 
lower half of the screen shows the Windows desktop. 

Returning to the Application 

To return to the application, do one of the following: 

� Select the App button on the top right side of the oscilloscope.  

� Select Analyze> Restore Application. 
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Exiting the Application 

To exit the application select File> Exit or select  from the right corner of the 
application.  

Application Directories and File Names 

The application uses specific directories to save and recall files. The following 
table lists the default directory names: 

Table 1: Application directories 
Directory  Function 
C:\TekApplications\TDSDVI\Setup Stores the application setup files 
C:\TekApplications\TDSDVI\Reports Stores the generated report 
C:\TekApplications\TDSDVI\Images Stores the zoomed eye images with the statistics 
C:\TekApplications\TDSDVI\Patterns Stores the Pseudo Random and the Half Clock 

Patterns 

File Name Extensions 

The application uses these file name extensions to identify the file type. The 
following table lists the file name extensions: 

Table 2: File name extensions 
File name extensions  Description 
.ini Application setup file 
.set Oscilloscope setup file saved and recalled with a .ini file; both 

the files will have the same file name 
.html Report file or a compared result file 
.bmp Format of the HCP and PRP pattern files 
.jpg Eye mask image file  
.gif Tektronix logo image 
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Operating Basics 

The TDSDVI application is a Windows-based application. The application 
window contains a Menu Bar, Device Selection Tab, Measurement Selection 
Pane and the Status Bar. 

You can select Transmitter, Cable, or Receiver from the Device Selection Tab. 
Select any of the device to display its measurement selection pane. 

Application Interface Controls 
The application uses a Window interface. 

Note: The oscilloscope application shrinks to half size and appears in the top 
half of the display when the application is running.  
 

The following table lists the application interface controls:  

Table 3: Application interface controls 
Control Description 
Menu bar Located at the top of the application window and provides access 

to the application menus 
Area/Tab Enclosed visual frame with a set of related options 
Option button Selects a command or task 
Drop-down List box Lists items from which you can select one item 
Field Box that you can use to type in text or to enter a value with the 

keypad or a multipurpose knob 
Check Boxes Box that you use to select or clear preferences 
Scroll bar Vertical or horizontal bar at the side or bottom of a display area 

used to move around that area 
Browse Displays a window where you can look through a list of 

directories and files 
Command button Initiates an immediate action 
Keypad Used to enter numeric values 
MP/GP knob Displays a line between the knob and the box. You can turn the 

knob on the oscilloscope to select a value 
 

Measurement Selection 
The measurement area, displayed in the center of the application window, 
displays the measurements you can select. These measurements vary depending 
on the selected tab. 
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The application has three tabs: the Transmitter, the Cable, and the Receiver, 
based on the device to be tested.  

Transmitter Tab 

If you select any measurement in the Transmitter Tab and click Configure, the 
configuration parameters for the selected measurement appears. 

 

Figure 2: Transmitter Tab 

The following figure shows the parameters you can configure for Transmitter 
measurements: 

 

Figure 3: Transmitter Measurements Matrix 

Cable Tab 

If you select any measurement in the Cable Tab and click Configure, the 
configuration parameters for the selected measurement appear. 
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Figure 4: Cable Tab 

The following figure shows the parameters you can configure for Cable 
measurement: 

 

Figure 5: Cable measurements matrix 
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Receiver Tab 

If you select any measurement in the Receiver Tab and click Configure, the 
configuration parameters for the selected measurement appear. 

 

Figure 6: Receiver tab 

The following figure shows the parameters you can configure for Receiver 
measurement: 

 

Figure 7: Receiver measurements matrix 

Device Selection Tab 

The device selection area is displayed above the measurement selection area of 
the application. You select the device based on your test. Click on any of the tabs 
to display the measurements associated with it. 

 

Figure 8: Transmitter, Cable, and Receiver tabs 
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Define Tbit Selection Area 

The Define Tbit Selection Area displayed next to the Measurement Selection 
Area, helps you to define the Tbit parameters for all the measurements. You can 
select the Calculated option to assign a channel for the Tx Clock and calculate 
Tbit or select the User option to set a custom value. The application displays the 
calculated value in the Tbit Value field. 

 

Figure 9: Define Tbit selection area 

Control Panel 

The control panel on the right of the application displays the dual-purpose 

Run/Stop button. The Run is a toggle button, which changes to Stop  

when you run any measurement.  

 

Figure 10: Control panel 
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The following table lists the control panel options: 

Table 4: Control panel  
Button Button Name Description 

 
 

 
 

Run/Stop Executes the selected measurement or stops 
the application when the application is running 

Status Bar 

The status bar is displayed at the bottom of the application window. It displays 
the selected menu, related hint, and the status of the application. 

 

Figure 11: Status Bar 

Menus 
The menu bar of the TDSDVI application provides access to the menus. 

 

Figure 12: Application menus 

File Menu 

 

Figure 13: File menu 
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The following table describes the file menu items: 

Table 5: File menu items and their descriptions 
Menu Selection Description 
Recall Default Recalls the default settings of the application 

Save Saves the application settings to a .ini file and the oscilloscope 
settings in a .set file 

Recall Recalls the previously saved settings of the application from an 
.ini file and the oscilloscope settings from a .set file 

Recently Saved Displays the recently saved setup 
Recently Recalled Displays the recently recalled setup 

Preferences 

Displays user preferences in two tabs 
In the General tab: 
� Use Cursors for Eye, RT & FT Testing 
� Prompt for signal connection  
� Ref Wfm deletion prompt for Eye Diagram Test 
� Show report after generation  
� Use zoomed eye mask in report  

In the Advanced tab: 
� Prompt for result reset  
� Prompt for Tbit validity  
� Select the test points for Cable Eye Diagram  
� Specifies the number of acquisitions to create Eye 

Diagram in the Value field. This input is common for the 
General and Advanced tab 

Minimize Minimizes the application window 
Exit Exits the application window 

Measurements Menu 

 

Figure 14:  Measurements menu 

The following table describes the measurement menu items: 

Table 6: Measurement menu items and their descriptions 
Menu Selection Description 
Select Allows you to select the measurements to be performed 
Configure Allows you to configure the parameters for the selected 

measurement 
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Results Menu 

 

Figure 15:  Results menu 

The following table describes the results menu items: 

Table 7: Results menu items and their descriptions 
Menu Selection Description 
Result Details Displays the detailed results of the selected measurement 

Utilities Menu 

 

Figure 16:  Utilities menu 

The following table describes the utilities menu items: 

Table 8: Utilities menu items and their descriptions 
Menu Selection Description 
Report Generator Displays the tabs— Report Setup and Report Name— to set the 

parameters for generating the reports 
Compare Results Allows you to compare the current displayed result with a previous 

result from a file or two previous results from two files 
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Help Menu 

 

Figure 17:  Help menu 

The following table describes the help menu items: 

Table 9: Help menu items and their descriptions 
Menu Selection Description 
Topics Displays the help for TDSDVI application 
About TDSDVI Displays a dialog box with the version number and the copyright 

information about the current version of the application 
Contact Tektronix Displays a dialog box with the contact email information 

Dialog Boxes 

Preferences 

Click File> Preferences to set the user preferences in two tabs: General and 
Advanced. 

In the General tab as shown in Figure 18, you can: 

� Use cursors for Eye, RT & FT testing 

� Prompt for signal connection 

� Ref Wfm deletion prompt for Eye tests 

� Show report after generation 

� Use zoomed eye mask in report 
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Figure 18:  General tab 

In the Advanced tab as shown in Figure 19, you can: 

� Prompt for result reset 

� Prompt for Tbit validity 

� Select Cable Eye Diagram Test Point 

 

Figure 19:  Advanced tab 

Number of Acquisitions field is common to the General and Advanced tabs. 
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The following table lists the options in the General and Advanced tab: 

Table 10: Preferences options and their descriptions 
Option Action 
Use Cursors for Eye, RT & 
FT testing  

Automatically enables the oscilloscope cursors to calculate the 
Vswing and the worst eye opening. 
The application enables the horizontal cursors to find the Vswing 
value. To calculate the Vswing value: 
� For the Eye Diagram and Rise and Fall Time measurements, 

place the cursors on the Vswing high and Vswing low of the 
eye diagram. 

The application enables the vertical cursors to select the worst eye 
opening. To select the worst eye opening: 
� Place the cursors at the crossover points of the worst eye 

opening for the Eye Diagram measurement. 
By default, the cursor option is not selected in the application.  

Prompt for signal connection Displays a message box prompting you to set up the connections 
and signal patterns when you run any measurement. 

Ref Wfm deletion prompt for 
Eye 

Displays a message box prompting you to save the Ref1 waveform 
with previous settings in another location because TDSDVI uses 
Ref1 for eye mask test and erases all the previous contents of Ref1. 
This happens when you run the Eye Diagram measurement. 

Show report after generation Automatically displays the report after the report is generated. 
Use zoomed eye mask in 
report 

In the generated report, the application uses the zoomed eye 
diagram with the mask. This is created using the Eye Zoom feature 
in Results> Result Detail> Eye zoom.  
If this checkbox is not selected, the application uses the 
oscilloscope screen shot of the eye diagram in the generated 
report. 

Prompt for result reset Displays a message box informing you that the previous results will 
be reset when you select the next measurement. This happens 
when you select successive measurements. 

Prompt for Tbit validity Displays a message box informing you to check the validity of Tbit 
calculation when you select any measurement and press the Run 
button. 

Select Cable Eye Diagram 
test point 

Specifies the different test points you can select to measure Cable 
Eye Diagram, such as TP2, TP3, or TP2 and TP3.  

Note: If you have a standard signal that passes a low or 
high amplitude mask, advanced users do not have to 
test the cable at TP2 with low or high amplitude mask 
every time they run the cable measurement. For this 
purpose, we recommend that you select the options in 
File> Preferences> Advanced> Cable Eye Diagram 
Test Point.  
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Table 10: Preferences options and their descriptions (Cont.) 

Option Action 

Number of Acquisitions—
Value 

Specifies the number of acquisitions to create an Eye mask. You 
can use the calculator keypad  or the GP knob next to the value 
field to enter the number of acquisitions.  
The DVI Test and Measurement Guide recommends one million 
acquisitions to perform an Eye Diagram measurement. 
For the CSA/TDS7404/B, TDS7254/TDS7254B, TDS7704B, 
DPO7354, and DPO/DSA70000 series oscilloscopes, you can set a 
maximum of five million and a minimum of five hundred thousand 
acquisitions. 
For theTDS6604, TDS6604B, TDS6404, and TDS6804 
oscilloscopes, you can set a maximum of one million and a 
minimum of ten thousand acquisitions. 

Recall Default 

Click File> Recall Default to replace the existing settings with the default 
settings. Select Yes to confirm the action and No to cancel the action. If you 
select Yes, the application displays the message box as shown in Figure 21. 

 

Figure 20: Recall Default message box 

 

Figure 21: Recall message box 

If you select No, the Recall Default dialog box disappears, and the application 
does not recall the default settings. 
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Calculator Keypad 

You can display the Calculator Keypad in the following ways: 

� File> Preferences> Value 

� Measurements> Select> Define Tbit> User>Value 

� Measurements> Select> Transmitter-Eye Diagram> Configure> User 

� Measurements> Select> Transmitter- Eye Diagram, Cable-High-
Amplitude/Low-Amp Eye Diagram, Receiver-High-Amplitude/Low-Amp 
Eye Diagram> Configure> Number of Eyes 

 

Figure 22: Calculator keypad 

The following table describes the calculator keypad options: 

Table 11: Calculator keypad keys and their descriptions 
Button Description 
Min Automatically displays the minimum value of the selected field  
Max Automatically displays the maximum value of the selected field  
CLR Clears the value for the field selected and returns to zero value 
BKSP Defines a backspace for the selected value  
Enter Enters the value for the selected field  
Esc Exits the calculator screen 
pHz-MHz Defines the frequency magnitude of the selected value  
 

To enter the values: 

1. Select the Min button to display the minimum value for the selected option. 

2. Select the Max button to display the maximum value for the selected option. 

3. Select the CLR button to erase the previous values. 

4. Select the numeric buttons to define the numeric values.  
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5. Select the Unit buttons to define the unit of the selected value.  

6. Select the Enter button to enter the numeric values. 

Virtual Keyboard 

You can display the Virtual Keyboard in the following ways: 

� Utilities> Report Generator> Report Setup> ID, Description, Prefix 

� Utilities> Report Generator> Report Name> File Name 

� Utilities> Compare Results> Select Files to Compare, Select Destination 
File 

 

Figure 23: Virtual Keyboard 

Use this dialog box to enter: 

� Device ID  

� Prefix  

� Description  

� File Name 

Use the keyboard to enter the data in the fields and then select the Enter button to 
complete your entry. 
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Exit 

Click File> Exit to exit the DVI application. When you exit the application, you 
can: 

� Restore the oscilloscope settings to their state prior to starting the 
application 

� Exit without changing the present oscilloscope settings 

 

Figure 24: Exit dialog box 

The following table describes the exit dialog box options: 

Table 12: Exit options and their descriptions 
Option Action 
Yes Restores the oscilloscope settings to their original state values prior to 

starting the application and exits 
No Exits the application without changing the present oscilloscope settings 
Cancel Cancels exiting the application 

Result Detail 

Click Results> Result Detail to display the result Details and Statistics for the 
selected measurement. The Statistics information is available only for the 
following measurements: 

� Transmitter Rise and Fall Time 

� Transmitter/Cable Intra-Pair Skew 

� Transmitter/Cable Inter-Pair Skew 
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Figure 25: Result Details for Transmitter Eye Diagram 

The following table describes the sample result details for Transmitter Eye 
Diagram: 

Table 13: Result details options and their descriptions 
Option Description 

Details tab 

Status The status of the measurement: Pass or Fail. 
Parameter The calculated parameters for the measurement. 
 Value The result parameters with the values. 
Compare Result The option to compare results from two different results. 
Eye Zoom The option to view a zoomed eye mask only for Eye diagram measurement. 
Generate Report The option to generate a report. 
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Report Generator 

Click Utilities> Report Generator to specify the report setup and report name 
information, and to generate reports. 

 

Figure 26: Report Setup tab 

 

Figure 27: Report Name tab 
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The following table describes the report generator options: 

Table 14: Report generator options and their descriptions 
Option Description 

Report Setup tab 
ID  Specifies the device ID. You can use the virtual keyboard and enter 

the device ID or type the data in the field and press Enter. 
Description Specifies the test device description for which the report is to be 

generated. You can use the virtual keyboard next to the description 
field to enter the device description. 

Automatic IDs and Report 
Names 

Generates and specifies the device ID and the report names 
automatically, if the check box is selected. The ID field is disabled if 
you select this option. Select the check box before you run the 
measurement. 

Prefix Displays the specified prefix of the device. This field is enabled, 
only if you select the Automatic mode of report generation. You can 
use the virtual keyboard to enter the device prefix or key in the data 
in the field and press Enter. 

Mode Displays the Manual or the Automatic mode of report generation. If 
you select the Manual mode, the Prefix field is disabled and you 
have to enter the device ID and description. If you select the 
Automatic mode, the Device ID field is disabled and the Automatic 
ID's and Report Names check box is selected. The application then 
generates a report with its naming conventions without user 
intervention. 
You can also check or uncheck the Automatic Device ID's and 
Report Names for the Manual and the Automatic modes. 

Defined Specifies the clock frequency values automatically when you define 
and calculate Tbit. 

Select for Report Displays the selected resolution and refresh rate in the generated 
report. 

Resolution  
Refresh Rate 

Displays the Resolution and Refresh Rate values as per the VESA 
standard. Use the drop-down arrow in the Resolution and Refresh 
Rate fields to set the values. Refer the topic, Reference> 
Resolutions for more information on the available resolutions. 

Generate Generates an .html report for the selected measurement. If you 
select the Automatic mode, this button is disabled. 
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Table 14: Report generator options and their descriptions (Cont.) 
Option Description 

Report Name Tab 

Directory Displays the directory location of the generated report.  

Browse Browses to the directory location. 

File Name Displays the file name of the report generated. Use the virtual 
keyboard to enter the file name or type the data in the field. If you 
select the Automatic mode, this field is disabled. 

Generate Generates an .html report for the selected measurement. If you 
select the Automatic mode, this button is disabled. 

 

To generate a report: 

1. Select Utilities> Report Generator. 

2. In the ID field, use the virtual keypad to enter the device ID. 

3. In the Description field, use the virtual keypad to enter the device 
description. 

4. Select Automatic IDs and Report Names box, if you want the application to 
generate a device ID and report names automatically. 

Note: Select the Automatic IDs and Report Names box before you run the 
measurement. 
 

5. In the Prefix field, use the virtual keypad to enter the device prefix. 

6. Select the Manual mode to generate report manually and the Automatic 
mode if you want the application to generate the report automatically.  

7. The Defined field automatically displays the predefined clock frequency 
values when you define and calculate Tbit. 

8. Select the Select for Report box, if you want the resolution and refresh rate 
values to generate the report. 

9. Use the drop-down arrow in the Resolution and Refresh Rate field to set the 
values according to the VESA standard. 

10. In the Report Name tab, select the Browse button to browse the directory 
location. 

11. In the File Name field, use the virtual keypad to enter the file name. Select 
the Generate button display an .html report. 
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Note: From this screen, you can use the Results button to view the results and the 
Compare Results option to compare results of two different devices. 

Eye Zoom 

Click Results> Result Detail> Eye Zoom to: 

� Display the zoomed worst eye opening with the mask  

� Use the cross haired cursors to find specific failed points and display their 
respective voltage and time values 

� Mark the failed data points in the eye mask to find specific failed points 
with markers. Markers are small red boxes that surround the failed points  

� Identify the failed points in red and the pass points in yellow  

� Save the eye mask for future reference to the default directory 
C:\TekApplications\TDSDVI\Images or any other directory of your choice  

� Identify the Hit Counts, Test Status, and Statistical information of the eye 
diagram 

 

Figure 28: Zoomed eye 

32                                       TDSDVI-DVI Compliance Test Solution 



Operating Basics 
 

To enable the Cursor or the Marker option: 

1. Select the ON button next to the cursor or marker option to enable cursors or 
markers. The X-axis of the cursor represents Time and the Y-axis represents 
Voltage. You can drag the cursor and position them anywhere on the eye 
mask. 

2. Select the OFF button next to the cursor or the marker option to disable the 
cursors or the markers. 

To save the zoomed eye mask: 

� Select the Save button to save the mask in .jpg format to the default 
directory C:\TekApplications\TDSDVI\Images or any other directory of 
your choice. You cannot save the image when the measurement is running. 

The following table describes the eye zoom options: 

Table 15: Eye zoom options and their descriptions 
Option Description 

Cursor Values Displays the cursor positions with reference to Voltage in volts and Time 
in seconds. 

Hit Counts Displays the number of data points in the fail zone. With reference to 
Figure 28, they are: 

• Upper: upper eye mask 
• Middle: middle eye mask 
• Lower: lower eye mask 

Status Displays the status of the test: Pass or Fail. 
Details Displays the result details for the zoomed eye mask. 

Compare Results 

Click Results> Compare Results to compare either: 

� The current results with results that are stored in a html file 

� Results that are stored in two different html files 

 

Figure 29: Compare results pane 
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The Current Vs File option displays two fields where you can enter: 

� The file name to be compared with the currently displayed results  

� The file name in which the compared results will be stored 

The File Vs File option displays three fields where you can enter: 

� The names of the html files to be compared 

� The name of the html file where the compared results will be stored 

The following figure lists the result combinations you can compare: 

 

Figure 30: Result comparison matrix 
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To compare the current result with a stored result: 

1. In the Select File(s) to compare Result field, select the Current Vs File 
option, and use the pop-up keyboard to enter the file name or use the browse 
button to browse for the file. You can also enter the file name directly in the 
field and press Enter. 

2. In the Select Destination File field, use the pop-up keyboard to enter the 
compared result file name or use the browse button to browse the file. 

3. Select the Compare button to complete the process. 

To compare results stored in two different files: 

1. In the Select File(s) to compare Result fields, select File Vs File option, and 
use the pop-up keyboard to enter the file names or use the browse button to 
browse the file. You can also enter the file name directly in the field and 
press Enter.  

2. In the Select Destination File field, use the pop-up keyboard to enter the 
name of the destination where you want to store the compared results or use 
the browse button to browse the file. You can also enter the file name 
directly in the field and press Enter.  

3. Select the Compare button to complete the process and display the 
compared report as shown in Figure 31. 
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Figure 31: Compared results 
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The following table describes the compare result options: 

Table 16: Compare results options and their descriptions 
Option Description 

Current Vs File Compares the current results with the results already stored in a file. 
File Vs File Compares the results stored in two different files. 
Results Displays the results panel for the selected measurement. 
Generate Report Displays the generate report panel for the selected measurement. 
Compare Compares the results based on the selected type. 

Eye Trends in TDS6604, TDS6404, TDS6604B, and TDS6804B Oscilloscopes 

Click Results> Result Detail> Eye Trend to: 

� Display the eye progression. 

� Display the Vertical and Horizontal trends of the eye diagram parameters 
such as Mask, Vswing, Overshoot, Undershoot, Tbit, Worst Tbit, Hopen, 
and Vopen. 
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Figure 32: Eye trends in TDS6000 series oscilloscopes 

To view the Eye Diagram Trends: 

1. Select the Eye Zoom button to display the zoomed eye mask or press the 
Eye Trend button in the results panel. 

2. Select the Go to Trend button to display the Vertical and Horizontal trends 
as shown in Figure 33. 

The TDS6604, TDS6404, TDS6604B, and TDS6804B oscilloscopes do not 
support FastAcq mode for gathering one million acquisitions, which is 
recommended for DVI compliance. The Eye-Trends feature on the TDS6604, 
TDS6404, TDS6604B, and TDS6804B oscilloscopes helps you to monitor eye 
formation and also look at the trends for important parameters, such as, Tbit, 
Hopen, Vopen, Worst Tbit, Overshoot and Undershoot. You can effectively test 
for DVI compliance by selecting a lower number of acquisitions. The Eye Trend 
begins with a minimum of 10K acquisitions to display the progression of the eye 
mask test in two trends, Vertical and Horizontal, in intervals of 30 seconds. 

In Vertical Trend, the X-axis represents the Number of Acquisitions and the Y-
axis represents Vopen in Volts. The Vertical Trend also displays Vopen, 
Overshoot, Undershoot and Vswing statistical results. 

In Horizontal Trend, the X-axis represents the Number of Acquisitions and the 
Y-axis represents Hopen in seconds. The Horizontal Trend also displays the 
Horizontal Opening, Crossover points, Worst Tbit and Tbit.  

Select the Zoom button to view the zoomed eye mask. Figure 33 shows the eye 
diagram parameters.  
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Figure 33: Eye definitions 

The following table describes the eye trend options: 

Table 17: Eye trend options and their descriptions 
Option Description 

Mask Is a set of polygons called mask segments that appears on the oscilloscope 
screen. If the waveform violates any one of the mask segments, the 
measurement fails the test; if the waveform does not violate any one of the 
mask segments, the measurement passes the test. 

Overshoot The voltage difference between the peak (positive or negative) and the 
normalized level (Vswing Low or Vswing High) in the eye mask. 

Undershoot The voltage difference between the minimum high level voltage or the 
maximum low-level voltage after the transition and the normalized voltage level 
(Vswing Low or Vswing High) in the eye mask. 

Vswing The voltage difference between the normalized high and low levels of the eye 
diagram. 
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Table 17: Eye trend options and their descriptions (Cont.) 
Option Description 

Tbit The time taken to transmit one bit of data. 
Worst Tbit The minimum distance between two consecutive crossover points in the eye 

diagram. 
Crossover The intersection or the overlapping of the rising and falling edges in an eye 

diagram.   
 

Select the View button to display the Statistics table. 

 

Figure 34: Eye trends statistical table 

The following table describes the statistical table: 

Table 18: Eye Trend-Statistics options and their descriptions 
Option Description 

Acqs No The number of acquisitions. 
Worst Tbit The minimum distance between two consecutive crossover points. 
Hopen The maximum horizontal opening between the closest hit points. 
Vopen The maximum vertical opening between the closest hit points. 
Overshoot  
(Top and Bottom) 

The voltage difference between the peak (positive or negative) and the 
normalized level (Vswing Low or Vswing High) in the eye mask. 
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Table 18: Eye Trend-Statistics options and their descriptions (Cont.) 
Option Description 

Undershoot  
(Top and Bottom) 

The voltage difference between the minimum high level voltage or the 
maximum low-level voltage after the transition and the normalized voltage 
level (Vswing Low or Vswing High) in the eye mask. 

Status The results of the selected measurement as Pass or Fail. 

Transmitter, Cable, and Receiver 
The application tests the signals for three types of devices: 

� Transmitter: Is a device that transmits DVI signals 

� Cable: Is a medium that transmits DVI signals from a transmitter to a 
receiver 

� Receiver: Is a device that receives DVI signals 

These devices are grouped into three tabs and have different measurements 
associated with them. 

Transmitter Eye Diagram 
Before using the application, set up the DUT as given in Application Examples> 
Transmitter-Eye Diagram> Equipment setup on page 141. 

Select the Transmitter tab and click the Eye Diagram measurement to display the 
following screen.  

 

Figure 35: Eye Diagram pane 
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Select the Eye Diagram measurement and click the Configure button to display 
the configuration parameters for the Transmitter Eye Diagram measurement. 

 

Figure 36: Eye Diagram Configuration 

Select Source 

Use the drop-down arrow in the Data box to select the data source channel. The 
available selections are: CH1 through CH4.  The application requires a recovered 
clock as an external trigger source to the oscilloscope. Use the drop-down arrow 
in the Trigger box to set the trigger source channel. The Data and Trigger sources 
are mutually exclusive. The Data and Trigger fields identify the data source and 
the external clock source. 

 

Figure 37: Select source 

Note: You cannot select the same channel for Data and Trigger. 
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Select Pair 

Use the drop-down arrow in the Select Pair box to set the data pair. The available 
data pairs are: 

� RX0 

� RX1 

� RX2 

Select the data pair from which you have probed the TPA-P fixture. 

 

Figure 38: Select pair 

Number of Eyes 

 

Figure 39: Number of eyes 

Use the GP knob or the calculator keypad  next to the Value field, to set the 
minimum number of eyes considered to find the worst eye opening in 
Transmitter, Cable, or Receiver Eye measurements. The application then 
positions the eye mask on the worst opening eye.  

You can set a minimum of two eyes to place the mask on the worst eye opening 
because the DVI specifications recommends at least two eyes to conduct the eye 
diagram test. 

To analyze the pixels, you can set a maximum of ten eyes because each data 
pixel has 10 bits. The application analyzes these eyes and places the mask at the 
worst eye opening. 
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Calculate Vswing 

 

Figure 40: Calculate Vswing  

Select the Pattern button to indicate the pattern you are using to calculate 
Vswing. The available patterns are: Pseudo Random Pattern (PRP) and Half 
Clock Pattern (HCP). If you select the User option, use the pop-up keypad in the 
Value field to enter the Vswing values. The range of the Vswing value is 200 
millivolts to 2 volts. The application uses the Vswing value to calculate the eye 
mask coordinates in Eye diagram measurement and the reference level in Rise 
Time and Fall Time measurement. 

To calculate Vswing:  

Select Pseudo Random Pattern or Half Clock from the drop-down list. To 
calculate Vswing accurately, use only the Half Clock Pattern because the HCP 
signal has less ringing than the PRP signal.  

If you select the Half Clock option, the application prompts you to connect the 
HCP and calculate the Vswing using the HCP signal. 

Select User option. In the Value field, use the calculator keypad to enter the 
Vswing values. The minimum value is 200 millivolts and the maximum is 2 
volts. The default value is 400 mV. If you are using this option, the application 
will not use a signal to calculate the Vswing. 

Transmitter Rise and Fall Time 
Before using the application, set up the DUT as given in Application Examples> 
Transmitter-Rise and Fall Time> Equipment Set up on page 144. 

According to the DVI specifications, Rise and Fall Time is defined as the time 
interval between the normalized 20% and 80% amplitude level of the TMDS 
(Transition Minimized Differential Signal) signal. 
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Select the Transmitter tab and click the Rise and Fall Time measurement to 
display the following screen:  

 

Figure 41: Rise and Fall Time pane 

Select Rise and Fall Time measurement and select the Configure button to 
display the configuration parameters for Rise and Fall Time measurement. 

 

Figure 42: Rise and Fall Time configuration 
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Select Source 

 

Figure 43: Select Source 

Use the drop-down arrow in the Data box to select the data source channel. The 
available selections are: Ch1 through Ch4. The application requires a recovered 
clock as an external trigger source to the oscilloscope. Use the drop-down arrow 
in the Trigger box to set the trigger source channel. The Data and Trigger sources 
are mutually exclusive. 

The Data and Trigger fields identify the data source and the external clock 
source. 

Note: You cannot select the same channel for Data and Trigger. 

Select Pair 

 

Figure 44: Select Pair 

Use the drop-down arrow in the Select Pair box to set the data pair. The available 
data pairs are: 

� RX0 

� RX1 

� RX2 

Select the data pair from which you have probed the TPA-P fixture. 
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Hysteresis 

Use the GP knob or the calculator keypad  next to the Value field to enter the 
hysteresis percentage value. The hysteresis range is 2% to 10%. 

 

Figure 45: Hysteresis 

Calculate Vswing 

 

Figure 46: Calculate Vswing 

Select the Pattern button to indicate the pattern you are using to calculate 
Vswing. The available patterns are: Pseudo Random Pattern (PRP) and Half 
Clock Pattern (HCP). If you select the User option, use the pop-up keypad in the 
Value field to enter the Vswing values. The range of the Vswing value is  
200 millivolts to 2 volts. The application uses the Vswing value to calculate the 
eye mask coordinates in Eye diagram measurement and the reference level in 
Rise Time and Fall Time measurement. 

To calculate Vswing:  

Select Pseudo Random Pattern or Half Clock from the drop-down list. To 
calculate Vswing accurately, we recommend that you use only the Half Clock 
Pattern because the HCP signal has less ringing than the PRP signal.  

If you select the Half Clock option, the application prompts you to connect the 
HCP and calculate the Vswing using the HCP signal. 

Select User option. In the Value field, use the calculator keypad to enter the 
Vswing values. The minimum value is 200 millivolts and the maximum is  
2 volts. The default value is 400 mV. If you are using this option, the application 
will not use a signal to calculate the Vswing.  
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Transmitter Pk-Pk Jitter 
Before using the application, set up the DUT as given in Application Examples> 
Transmitter-Pk-Pk Jitter> Equipment Setup on page 147. 

Select the Transmitter tab and click the Pk-Pk Jitter measurement to display the 
following screen:  

 

Figure 47: Pk-Pk Jitter pane 

Select the Pk-Pk Jitter measurement and press the Configure button to display the 
configuration parameters for the Pk-Pk Jitter measurement. 

 

Figure 48: Pk-Pk Jitter configuration 
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Select Source 

 

Figure 49: Select Source 

Use the drop-down arrow in the Tx Clock box to select the transmitted 
differential clock source channel. The available selections are: CH1 through 
CH4. The application requires a CRU (Clock Recovery Unit) to trigger the 
oscilloscope. Use the drop-down arrow in the Trigger box to set the trigger 
source channel. Data and Trigger source are mutually exclusive. 

The Tx Clock and Trigger fields identify the Tx clock source and the Clock 
Recovery Unit source. 

Note: You cannot select the same channel for Tx clock and Trigger. 

Transmitter Intra-Pair Skew 
Before using the application, set up the DUT as given in Application Examples> 
Transmitter-Intra-Pair Skew> Equipment Setup on page 150. 

Intra-Pair skew is the Skew between the signal that constitutes from the same 
pair  (Example Rx0+ and Rx0−) at TP2.  
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Select the Transmitter tab and click the Intra-Pair Skew measurement to display 
the following screen: 

 

Figure 50: Intra-Pair Skew pane 

Select the Intra-Pair Skew measurement and press the Configure button to 
display the configuration parameters for the Intra-Pair Skew measurement. 

 

Figure 51: Intra-Pair Skew configuration 

50                                       TDSDVI-DVI Compliance Test Solution 



Operating Basics 
 

Select Source 

 

Figure 52: Select Source 

Use the drop-down arrow in the Source1 box to set the data line (+) of the data 
pair. The available selections are: CH1 through CH4. Use the drop-down arrow 
in the Source2 box to set the data line (−) of the data pair. The Source channels 
are mutually exclusive. Use two single-ended probes to connect the data pair (for 
example: Rx0+ or Rx0−) to Source1 and Source2.  

The Source field identifies a data line. 

Note: You cannot select the same channel for Source1 and Source2. 

Select Pair 

 

Figure 53: Select Pair 

Use the drop-down arrow in the Select Pair box to set the data pair. The available 
data pairs are: 

� RX0 

� RX1 

� RX2 

Select the data pair to which you have probed the TPA-P fixture for Transmitter 
device and TPA-R fixture for a Cable and Receiver device. 
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Hysteresis 

 

Figure 54: Hysteresis 

Use the GP knob or the calculator keypad  next to the Value field to enter the 
hysteresis percentage value.  

The hysteresis range is 2% to 10%. 

Transmitter Inter-Pair Skew  
Before using the application, set up the DUT as given in Application Examples> 
Transmitter-Inter-Pair Skew> Equipment Setup on page 153. 

Inter-pair skew is the time delay between the different data pairs (Example Rx0+ 
of one pair and Rx1− of the other pair). 

Select the Transmitter tab and click the Inter-Pair Skew measurement to display 
the following screen:  

 

Figure 55: Inter-Pair Skew pane 
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Select the Inter-Pair Skew measurement and press the Configure button to 
display the configuration parameters for the Inter-Pair Skew measurement. 

 

Figure 56: Inter-Pair Skew configuration 

Select Source 

 

Figure 57: Select Source 

Use the drop-down arrow in the Source1 box to set the data line (+) of the data 
pair. The available selections are: CH1 through CH4. Use the drop-down arrow 
in the Source2 box to set the data line (−) of the data pair. The Source channels 
are mutually exclusive. Use two single-ended probes to connect the data pair (for 
example: Rx0+ or Rx0−) to Source1 and Source2.  

The Source field identifies a data line. 

Note: You cannot select the same channel for Source1 and Source2. 
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Select Pair 

 

Figure 58: Select Pair 

Use the drop-down arrow in the Pair1 and Pair2 box to set the differential data 
pair. The available data pairs are: 

� RX0 

� RX1 

� RX2 

If the data line is positive, select the check box next to the Pair fields. If you 
select the Differential Probe box, the positive check boxes next to the pair fields 
are disabled and the application calculates the time delay between the two data 
pairs. If you used a single-ended probe, the application calculates the skew 
between the data lines. 

Select the data pair from which you have probed the TPA-P fixture. You cannot 
select the same data pair in the Pair1 and Pair2 boxes irrespective of the polarity 
(+ or −). 

Hysteresis 

 

Figure 59: Hysteresis 

Use the GP knob or the calculator keypad  next to the Value field to enter the 
hysteresis percentage value.  

The hysteresis range is 2% to 10%. 
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Cable High-Amplitude/Low Amplitude Eye Diagram  
Before using the application, set up the DUT as given in Application Examples> 
Cable-High-Amplitude/Low Amplitude Eye Diagram> Equipment Setup  
on page 162. 

Select the Cable tab and click the High-Amp Eye Diagram measurement to 
display the following screen:  

 

Figure 60: High-Amplitude Eye Diagram pane 

Select the High-Amplitude Eye Diagram measurement and press the Configure 
button to display the configuration parameters for High-Amplitude Eye Diagram 
measurement. 

 

Figure 61: High-Amplitude Eye Diagram configuration 

Before using the application, set up the DUT as given in Application Examples> 
Transmitter-Eye Diagram> Equipment Setup on page 162. 
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Select the Cable tab and click the Low-Amp Eye Diagram measurement to 
display the following screen:  

 

Figure 62: Low-Amplitude Eye Diagram pane 

Select the Low-Amplitude Eye Diagram measurement and press the Configure 
button to display the configuration parameters for Low-Amplitude Eye Diagram 
measurement. 

 

Figure 63: Low-Amplitude Eye Diagram configuration 
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Select Source 

 

Figure 64: Select Source 

Use the drop-down arrow in the Data box to select the data source channel. The 
available selections are: CH1 through CH4.The application requires a recovered 
clock as an external trigger source to the oscilloscope. Use the drop-down arrow 
in the Trigger box to set the trigger source channel. The Data and Trigger sources 
are mutually exclusive. 

The Data and Trigger fields identify the data source and the external clock 
source. 

Note: You cannot select the same channel for Data and Trigger. 

Select Pair 

 

Figure 65: Select Pair 

Use the drop-down arrow in the Select Pair box to set the data pair. The available 
data pairs are: 

� RX0 

� RX1 

� RX2 

Select the data pair to which you have probed the TPA-P fixture for Transmitter 
device and TPA-R fixture for a Cable and Receiver device. 
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Number of Eyes 

 

Figure 66: Number of Eyes 

Use the GP knob or the calculator keypad  next to the Value field to set the 
minimum number of eyes considered to find the worst eye opening in 
Transmitter, Cable, or Receiver Eye measurements. The application then 
positions the eye mask on the worst opening eye.  

You can set a minimum of two eyes to place the mask on the worst eye opening 
because the DVI specifications recommend at least two eyes to conduct the eye 
diagram test. 

To analyze the pixels, you can set a maximum of ten eyes because each data 
pixel has 10 bits. The application analyzes these eyes and places the mask at the 
worst eye opening. 

Cable Pk-Pk Jitter 
Before using the application, set up the DUT as given in Application Examples> 
Cable-Pk-Pk Jitter> Equipment Setup on page 156. 

Select the Cable tab and click the Pk-Pk Jitter measurement to display the 
following screen:  

 

Figure 67: Pk-Pk Jitter pane 
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Select the Pk-Pk Jitter measurement and press the Configure button to display the 
configuration parameters for the Pk-Pk Jitter measurement.  

 

Figure 68: Pk-Pk Jitter configuration 

Select Source 

 

Figure 69: Select Source 

Use the drop-down arrow in the Tx Clock box to select the transmitted 
differential clock source channel. The available selections are: CH1 through 
CH4. The application requires a CRU (Clock Recovery Unit) to trigger the 
oscilloscope. Use the drop-down arrow in the Trigger box to set the trigger 
source channel. Data and Trigger source are mutually exclusive. 

The Tx Clock and Trigger fields identify the Tx clock source and the Clock 
Recovery Unit source. 

Note: You cannot select the same channel for Tx clock and Trigger. 
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Cable Intra-Pair Skew 
Before using the application, set up the DUT as given in Application Examples> 
Cable-Intra-Pair Skew> Equipment Setup on page 157. 

Cable Intra-Pair skew is the skew between the signal that constitutes from the 
same pair  (Example Rx0+ and Rx0−) at TP3.  

Select the Cable tab and click the Intra-Pair Skew measurement to display the 
following screen measurement:  

 

Figure 70: Intra-Pair Skew pane 

Select the Intra-Pair Skew measurement and press the Configure button to 
display the configuration parameters for the Intra-Pair Skew measurement. 

 

Figure 71: Intra-Pair Skew Configuration 
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Select Source  

 

Figure 72: Select Source 

Use the drop-down arrow in the Source1 box to set the data line (+) of the data 
pair. The available selections are: CH1 through CH4. Use the drop-down arrow 
in the Source2 box to set the data line (−) of the data pair. The Source channels 
are mutually exclusive. Use two single-ended probes to connect the data pair (for 
example: Rx0+ or Rx0−) to Source1 and Source2.  

The Source field identifies a data line. 

Note: You cannot select the same channel for Source1 and Source2. 

Select Pair 

 

Figure 73: Select Pair 

Use the drop-down arrow in the Select Pair box to set the data pair. The available 
data pairs are: 

� RX0 

� RX1 

� RX2 

Select the data pair to which you have probed the TPA-P fixture for Transmitter 
device and TPA-R fixture for a Cable and Receiver device. 
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Hysteresis 

 

Figure 74: Hysteresis 

Use the GP knob or the calculator keypad  next to the Value field to enter the 
hysteresis percentage value.  

The hysteresis range is 2% to 10%. 

Cable Inter-Pair Skew  
Before using the application, set up the DUT as given in Application Examples> 
Cable-Inter-Pair Skew> Equipment Setup on page 160. 

Inter-Pair skew is the skew between the signal that constitutes from the different 
pair (Example Rx0+ of one pair and Rx0− of the other pair). 

Select the Cable tab and click the Inter-Pair Skew measurement to display the 
following screen:  

 

Figure 75: Inter-Pair Skew pane 

Select the Inter-Pair Skew measurement and press the Configure button to 
display the configuration parameters for the Inter-Pair Skew measurement. 
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Figure 76: Inter-Pair Skew configuration 

Select Source 

 

Figure 77: Select Source 

Use the drop-down arrow in the Source1 box to set the data line (+) of the data 
pair. The available selections are: CH1 through CH4. Use the drop-down arrow 
in the Source2 box to set the data line (−) of the data pair. The Source channels 
are mutually exclusive. Use two single-ended probes to connect the data pair (for 
example: Rx0+ or Rx0−) to Source1 and Source2.  

The Source field identifies a data line. 

Note: You cannot select the same channel for Source1 and Source2. 
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Select Pair 

 

Figure 78: Select Pair 

Use the drop-down arrow in the Pair1 and Pair2 box to set the differential data 
pair. The available data pairs are: 

� RX0 

� RX1 

� RX2 

If the data line is positive, select the check box next to the Pair fields. If you 
select the Differential Probe box, the positive check boxes next to the pair fields 
are disabled and the application calculates the time delay between the two data 
pairs. If you used a single-ended probe, the application calculates the skew 
between the data lines. 

Select the data pair from which you have probed the TPA-P fixture. You cannot 
select the same data pair in the Pair1 and Pair2 boxes, irrespective of the polarity 
(+ or −). 

Hysteresis 

 

Figure 79: Hysteresis 

Use the GP knob or the calculator keypad  next to the Value field to enter the 
hysteresis percentage value.  

The hysteresis range is 2% to 10%. 
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Receiver High-Amplitude/Low Amplitude Eye Diagram 
Before using the application, set up the DUT as given in Application Examples> 
Receiver-High Amplitude/Low Amplitude Eye Diagram> Equipment Setup  
on page 167. 

Select the Receiver tab and click the High-Amp Eye Diagram measurement to 
display the following screen:  

 

Figure 80: High-Amplitude Eye Diagram pane 

Select the High-Amplitude Eye Diagram and press the Configure button to 
display the configuration parameters for the High-Amplitude Eye Diagram 
measurement. 

 

Figure 81: High-Amplitude Eye Diagram configuration 
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Select the Receiver tab and click the Low-Amp Eye Diagram measurement to 
display the following screen:  

 

Figure 82: Low-Amplitude Eye Diagram pane 

Select the Low-Amplitude Eye Diagram and press the Configure button to 
display the configuration parameters for the Low-Amplitude Eye Diagram 
measurement. 

 

Figure 83: Low-Amplitude configuration 
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Select Source 

 

Figure 84: Select Source 

Use the drop-down arrow in the Data box to select the data source channel. The 
available selections are: Ch1 through Ch4. The application requires a recovered 
clock as an external trigger source to the oscilloscope. Use the drop-down arrow 
in the Trigger box to set the trigger source channel. The Data and Trigger sources 
are mutually exclusive. 

The Data and Trigger fields identify the data source and the external clock 
source. 

Note: You cannot select the same channel for Data and Trigger. 

Select Pair 

 

Figure 85: Select Pair 

Use the drop-down arrow in the Select Pair box to set the data pair. The available 
data pairs are: 

� RX0 

� RX1 

� RX2 

Select the data pair to which you have probed the TPA-P fixture for Transmitter 
device and TPA-R fixture for a Cable and Receiver device. 
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Number of Eyes 

 

Figure 86: Number of Eyes 

Use the GP knob or the calculator keypad  next to the Value field to set the 
minimum number of eyes considered to find the worst eye opening in 
Transmitter, Cable, or Receiver Eye measurements. The application then 
positions the eye mask on the worst opening eye.  

You should set a minimum of two eyes to place the mask on the worst eye 
opening because the DVI specifications recommend at least two eyes to conduct 
the eye diagram test. 

To analyze the pixels, you can set a maximum of ten eyes because each data 
pixel has 10 bits. The application analyzes these eyes and places the mask at the 
worst eye opening. 

Calculate Tbit 

 

Figure 87: Define Tbit pane 

Tbit is the time required to transmit one bit of data. The Define Tbit pane is 
independent of all the measurements. A valid Tbit value is required for all 
measurements. If the device, resolution, blanking rate, or the refresh rate 
changes, you have to recalculate Tbit. The Tx Clock field identifies the external 
clock source.  

Note: We recommend that you calculate the Tbit with the differential transmitted 
clock rather than defining Tbit values yourself. You need to calculate Tbit only 
once for a device working at a particular resolution, refresh rate, or blanking 
rate. This value will be retained for further measurements. If the device, 
resolution, refresh rate, or blanking rate changes, you have to recalculate Tbit. 
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To calculate Tbit, 

1. Select the Tbit button to enable the Define Tbit pane.  

2. Select the Calculated radio button to use the differential transmitted clock 
and calculate Tbit.  

3. Select the Tx Clock channel from the Tx Clock drop-down list. The 
available selections are: Ch1 through Ch4.  

4. Click the Run button to calculate Tbit. The application displays the 
following message box. (This message box is not displayed if you have not 
selected the File> Preferences> Prompt for signal connection check box.) 

 

Figure 88: Connect differential clock message box 

5. Select OK to confirm the connection. You can select the Cancel button to 
cancel the process. 

6. After calculating Tbit, the application displays the following message box 
and the value in the Tbit Value field. 

 

Figure 89: Successful Tbit calculation message box 

Enter a User Defined Tbit Value 

1. Select the Tbit button to enable the Define Tbit pane.  

2. Select the User radio button if you want to define the Tbit values yourself. 

3. Use the calculator keypad or the GP knob next to the Value field to set the 
Tbit value.  
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The acceptable ranges for Tbit Values are: 

� TDS66604, TDS6404, TDS6604B, TDS6804B, TDS7404, TDS7404B, 
TDS7704B, CSA7404, CSA7404B, DPO7354, and DPO/DSA70000 series 
oscilloscopes—200 ps to 20 ns.  

� TDS7254 and TDS7254B oscilloscopes—1ns to 20 ns. 

Troubleshooting Tbit Calculation Error Messages  

� The application displays the following message box if the Tbit value is not 
within the specified range. The acceptable ranges for Tbit Values are: 

� TDS66604, TDS6404, TDS6604B, TDS6804B, TDS7404, TDS7404B, 
TDS7704B, CSA7404, CSA7404B, DPO7354, and DPO/DSA70000 
series oscilloscopes —200 ps to 20 ns.  

� TDS7254 and TDS7254B oscilloscopes—1ns to 20 ns.  

 

Figure 90: Invalid Tbit value message box 

� The application displays the following message box if the Tbit calculation 
has failed. This happens if you have not used a clock signal. 

 

Figure 91: Tbit calculation failure message box 
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� If you select the Tbit option and press the Configure button, the application 
displays the following message box. To avoid this, configure the Tbit value 
in the Define Tbit pane and press the Run button. 

 

Figure 92: Select measurement message box 

� If you select the User option and press the Configure button, the application 
displays the following message box: 

 

Figure 93: Tbit defined message box 

Test Transmitter For Eye Diagram 

Selecting and Configuring Eye Diagram 

Follow these steps to select and configure the Eye Diagram: 

Note: Refer to page 141 to set up the DUT before using the application.  
 

1. Select Measurements> Select> Transmitter>Eye Diagram to display the Eye 
Diagram screen. 

 

Figure 94: Eye Diagram pane 
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2. You have to define Tbit: 

� If you have not calculated the Tbit value   

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  

3. Select the Configure button to display the following screen: 

 

Figure 95: Eye Diagram configuration 

4. In the Select Source pane, select the data source channel from the Data 
drop-down list. This indicates which channel is connected in the TPA-P 
fixture with a differential probe. The available selections are: CH1 through 
CH4. The application requires a recovered clock as an external trigger 
source to the oscilloscope. Use the drop-down arrow in the Trigger field to 
set the trigger source channel. The available selections are: CH1 through 
CH4. You cannot set the same channel for Data and Trigger source. 

5. Use the drop-down arrow in the Pair field to set the data pair. The available 
data pairs are: 

� RX0 

� RX1 

� RX2 

Note: The data pair values appear only in the generated report and are not used 
for any calculations. 
 

6. In the Number of Eyes field, use the GP knob or the calculator keypad  
next to the Value field, to enter the minimum number of eyes to be 
considered to perform the test. 
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7. From the Calculate Vswing pane, you can calculate Vswing in two ways:  

� Select the Pattern button. Use the drop-down arrow to select the Pseudo 
Random or Half Clock to specify the pattern you want to use to 
calculate Vswing. 

� If you know the Vswing value, select the User button. In the Value 
field, use the pop-up keyboard to enter your user-defined Vswing 
values. The default pattern is PRP. 

8. Press the Run button  to perform the test. The application displays 

the Confirm Tbit Value message box. 

9. If you have defined the Tbit value, the application displays the Eye Mask 
message box. 

10. If you have selected Half Clock Pattern, the application displays the 
following message box. Transmit the HCP from the DUT, connect the 
signals to the oscilloscope, and select OK. 

 

Figure 96: Half clock pattern message box 

11. If you have selected PRP to calculate Vswing, the application displays the 
following message box. Transmit the PRP in the DUT, connect the signals 
to the oscilloscope and select OK. 

 

Figure 97: PRP message box 
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12. If you are using a TDS6000 series oscilloscopes: 

� If you have selected Half Clock Pattern in TDS6000 series 
Oscilloscopes, the application displays the following message box. 
(You can select the Stop button to stop the process and the Skip button 
to measure the Vswing with the current number of available 
acquisitions.) 

 

Figure 98: Wait message box 

� If you have selected File> Preferences> Use Cursors for Eye, RT & FT 
Testing, the application enables the cursors on the oscilloscope to 
calculate the Vswing. 

� After calculating Vswing using the Half Clock Pattern, the application 
displays the message box, "Connect the PRP pattern". Remove the 
TPA-P fixture from the DUT and connect the DVI monitor. Change the 
PRP pattern and remove the DVI monitor from the DUT. Connect the 
TPA-P fixture to the DUT and probe the selected data pair from the 
TPA-P and press OK to display the following message box. 

 

Figure 99: Monitor eye progress message box 

� Select Yes to display the Eye Zoom screen. If you select No, the 
application continues to run the measurement. 

(If you have selected File> Preferences> Use Cursors for Eye, RT & 
FT Testing, the application displays only the Wait message box.) 

The application tests the signal with the transmitter eye mask and displays the 
results. 
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Viewing Results for Eye Diagram 

Follow these steps to view Eye Diagram results: 

1. Select Results> Result Detail to display the detailed results for the 
Transmitter Eye Measurement. 

You can also use the: 

� Compare Result button to compare results  

� Eye Zoom button to view the zoomed eye  

� Generate Report button to generate reports 

 

Figure 100: Eye Diagram results 
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The following table describes the eye diagram result options 

Table 19: Results: Eye diagram options and their descriptions 
Results Description 
Parameter Displays the calculated parameters for the measurement, such as Tbit, 

Acquisition Number, Vswing, Worst Tbit, Overshoot, Undershoot, Vopen, 
Hopen, and Hit Counts. 

Value Displays the values of: 
• Tbit used for calculating the coordinates of the eye mask 
• Calculated Worst Tbit  
• The number of acquisitions to create the eye diagram 
• Calculated Vswing in volts  
• Calculated Overshoot and Undershoot of the eye diagram  
• Vopen in volts and Hopen in seconds  
• The number of Hit counts on the eye mask 

Status Displays the result status: Pass or Fail. 

Generating Reports for Eye Diagram 

Note: Select File> Export Setup> Images> Data Format from the oscilloscope 
menu. Set the data format option to .jpg before generating a report. The report 
format does not support any other image file. Before you run the measurement, 
select Automatic IDs & Report Names to automatically generate a report. 
 

Follow these steps to generate a report for all the measurements: 

1. Select Reports> Report Generation to display the following screen. 

 

Figure 101: Generate report, report setup tab 

2. In the Report Setup tab, use the virtual keypad to enter the device ID. 

3. In the Description field, use the virtual keypad to enter the device 
description. 
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4. If you have not yet run the measurement, and if you want the application to 
display the device ID and specify the report names automatically, select the 
Automatic IDs & Report Names box. The ID field is disabled if you select 
this option. The ID, File Name fields, and Generate button are disabled if 
this option is selected.  

5. In the Prefix field, use the virtual keypad to enter the device prefix. 

6. Select the Mode of generating the report: Manual or Automatic. If you select 
the Manual mode, the Prefix field is disabled. If you select the Automatic 
mode, Device ID field is disabled. 

7. The Defined field displays the predefined clock frequency values 
automatically when you define and calculate Tbit.  

8. Use the drop-down arrow in the Resolution and Refresh Rate field to set the 
values and calculate the clock frequency. The drop-down list provides the 
Resolution and Refresh Rate values according to the VESA standard. If you 
select the Select for Report box, the application displays the resolution and 
refresh rate in the generated report. 

9. If you do not want to specify the report details, select the Generate button. 
You can do this only if you have selected the Manual mode of generating a 
report. If you want to specify the report details, perform the following steps: 

 

Figure 102: Generate Report, report name tab 

a. In the Report Name tab, select the Browse button in the Directory field to 
browse to the directory location. 

b. In the File Name field, use the virtual keypad to enter the file name. 

c. You can use the Results option to view the results and the Compare Results 
option to compare results of two different devices. 

d. Select the Generate button to generate report an HTML report. Figure 103 
shows a sample Eye Diagram report. 
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Figure 103: Eye Diagram report 
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Test Transmitter for Rise Time and Fall Time 

Selecting and Configuring Measurements: Rise and Fall Time 

Follow these steps to select and configure Rise and Fall Time: 

Note: Refer to page 144 to set up the DUT before using the application. 
 

1. Select Measurements> Select> Transmitter> Rise and Fall Time to display 
the following screen:  

 

Figure 104: Rise and Fall Time pane 

2. You have to define Tbit: 

� If you have not calculated the Tbit value   

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  

3. Select the Configure button to display the following screen: 

 

Figure 105: Rise and Fall Time configuration 

4. Use the drop-down arrow in the Data field to select the data source channel. 
The available selections are: CH1 through CH4.The application requires a 
recovered clock as an external trigger source to the oscilloscope. Use the 
drop-down arrow in the Trigger field to set the trigger source channel.  
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5. Use the drop-down arrow in the Select Pair field to set the data pair. The 
available data pairs are: 

� RX0 

� RX1 

� RX2 

6. In the Hysteresis field, use the GP knob or the calculator keypad  to enter 
the hysteresis percentage value. The hysteresis range is 2% to 10%. 

7. From the Calculate Vswing pane, you can calculate Vswing in two ways:  

� Select the Pattern button. Use the drop-down arrow to select the Pseudo 
Random or Half Clock to specify the pattern you want to use to 
calculate Vswing. 

� If you know the Vswing value, select the User button. In the Value 
field, use the calculator keypad  to enter the user defined Vswing 
values. The default pattern is PRP.  

8. Press the Run button to perform the test. The application displays the 
Confirm Tbit Value message box. 

9. If you have selected Half Clock Pattern, the application displays the 
following message box. Generate the HCP in the DUT and select OK.  
Refer to page 191 on how to generate the HCP in the DUT. 

 

Figure 106: HCP message box 
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10. If you have selected PRP to calculate the Vswing, the application displays 
the PRP message box. Generate the PRP in the DUT and select OK.  
Refer to page 191 on how to generate the PRP in the DUT. 

 

Figure 107: PRP message box 

11. If you are using a TDS6604, TDS6404, TDS6604B, or TDS6804B 
oscilloscope.  

� Select the Stop button to stop the process. If you select the Skip button, 
the application measures the Vswing with the current number of 
acquisitions. 

 

Figure 108: Wait message box 

12. If you have selected File> Preferences> General> Use cursors for Eye, RT 
& FT Testing, refer to page 191 for information on what the application 
does to calculate Vswing. The application calculates the Rise and Fall time 
and displays the results. 

Viewing Results for Rise and Fall Time 

Follow these steps to view Rise and Fall Time results: 

1. Select Results> Result Detail to display the detailed and statistical results for 
the Transmitter Rise and Fall Time Measurement. 

You can use: 

� Compare Result button to compare results  

� Generate Report button to generate reports 
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Figure 109: Rise and Fall Time results-Details 

 

Figure 110: Rise and Fall Time results-Statistics 
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The following table describes the rise and fall time result options: 

Table 20: Results: Rise and Fall time options and their descriptions 
Results Description 
Details tab 
Parameter Displays the calculated parameters for the measurement, such as Tbit, Vswing, 

Worst Tbit, Lower Limits, and Upper Limits for Rise Time and Fall Time. 
Value Displays the values of: 

• Tbit used for calculating the limits of Rise and Fall Time  
• Calculated Vswing in volts  
• Calculated Overshoot, Undershoot of the eye diagram  
• Vopen in millivolts and Hopen in seconds  
• The measured Rise time and Fall time value in seconds 
• The lower limit for Rise time and Fall time. Values below this limit indicate a 

Fail 
• The upper limit for Rise time and Fall time. Values above this limit indicate 

a Fail 
Statistics tab 
Measurement Displays the selected measurement. 
Population The number of edges calculated in the acquired waveform. 
Min The minimum Rise and Fall Time value in the acquired waveform. 
Max The maximum Rise and Fall Time value in the acquired waveform. 
Mean The average of all the calculated Rise Time values. 
Std Dev The standard deviation of all the calculated Rise and Fall time values. 
Status Displays the result status: Pass or Fail. This is common to both the Details and 

Statistics tab. 

Generating Reports for Rise Time and Fall Time 

Follow these steps to generate a report for all the measurements: 

Note: Select File> Export Setup> Images> Data Format from the oscilloscope 
menu. Set the data format option to .jpg before generating a report. The report 
format does not support any other image file. Before you run the measurement, 
select Automatic IDs & Report Names to automatically generate a report. 
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1. Select Reports> Report Generation to display the following screen. 

 

Figure 111: Generate Report, report setup 

2. In the Report Setup tab, use the virtual keypad to enter the device ID. 

3. In the Description field, use the virtual keypad to enter the device 
description. 

4. If you have not yet run the measurement, and if you want the application to 
display the device ID and specify the report names automatically, select the 
Automatic IDs & Report Names box. The ID field is disabled if you select 
this option. The ID, File Name fields, and Generate button are disabled if 
this option is selected.  

5. In the Prefix field, use the virtual keypad to enter the device prefix. 

6. Select the Mode of generating the report: Manual or Automatic. If you select 
the Manual mode, the Prefix field is disabled. If you select the Automatic 
mode, Device ID field is disabled. 

7. The Defined field displays the predefined clock frequency values 
automatically when you define and calculate Tbit.  

8. Use the drop-down arrow in the Resolution and Refresh Rate field to set the 
values and calculate the clock frequency. The drop-down list provides the 
Resolution and Refresh Rate values according to the VESA standard. If you 
select the Select for Report box, the application displays the resolution and 
refresh rate in the generated report. 

9. If you do not want to specify the report details, select the Generate button. 
You can do this only if you have selected the Manual mode of generating a 
report. If you want to specify the report details, perform the following steps: 
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Figure 112: Generate Report, report name 

a. In the Report Name tab, select the Browse button in the Directory field to 
browse to the directory location. 

b. In the File Name field, use the virtual keypad to enter the file name. 

c. You can use the Results option to view the results and the Compare Results 
option to compare results of two different devices. 

d. Select the Generate button to generate report an HTML report.  

Test Transmitter for Pk-Pk Jitter 

Selecting and Configuring Measurements: Pk-Pk Jitter 

You can select Pk-Pk Jitter in the following ways: 

� Measurement> Select> Transmitter> Pk-Pk Jitter 

� Measurement> Select> Cable> Pk-Pk Jitter 

Note: Refer to page 147 to set up the DUT before using the application for 
Transmitter Pk-Pk Jitter. 

Refer to page 156 to set up the DUT before using the application for Cable Pk-
Pk Jitter 

To get appropriate results in Pk-Pk Jitter measurements, from the oscilloscope 
menu bar, select Measure>Waveform Histograms>Adjust Histogram Box Limits.  
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Follow these steps to select and configure Pk-Pk Jitter: 

1. Select Measurements> Select> Transmitter/Cable> Pk-Pk Jitter to display 
the screen:  

 

Figure 113: Transmitter Pk-Pk Jitter pane 

 

Figure 114: Cable Pk-Pk Jitter pane 

2. You have to define Tbit: 

� If you have not calculated the Tbit value  

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  

3. Select the Configure button to display the following screen: 

 

Figure 115: Transmitter Pk-Pk Jitter configuration 
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Figure 116: Cable Pk-Pk Jitter configuration 

4. Select the transmitted differential clock source from the Tx Clock drop-
down list. The available selections are: CH1 through CH4. The application 
requires a CRU (Clock Recovery Unit) to trigger the oscilloscope. Set the 
trigger source channel from the Trigger drop-down list. Data and Trigger 
source are mutually exclusive.  

5. Press the Run button  to perform the test. The application displays 

the Confirm Tbit Value message box. 

6. Confirm the Tbit value to display the following message box. Connect the 
clock signals and press OK. 

 

Figure 117: Clock signals message box 

The application calculates the Pk-PK Jitter and displays the result: Pass or Fail. 

Note: For more in-depth analysis on Jitter, use the TDSJIT3 Package. 
 

If the signal is unstable, the application cannot place the histogram at the second 
rising edge of the clock signal, then the application displays the following 
message box. 
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Figure 118: Holdoff message box 

To adjust the Trigger Holdoff time:  

1. Select Trig> Holdoff from the oscilloscope interface. 

2. Use the GP knob on the oscilloscope panel to adjust the trigger hold off 
time. 

3. After stabilizing the signal, press the APP button in the oscilloscope 
interface to display the application. 

4. Press OK to continue the peak-to-peak jitter measurement and Cancel to 
stop running the measurement. 

 

Figure 119: Oscilloscope interface 

Viewing Results for Pk-Pk Jitter  

Follow these steps to view Pk-Pk Jitter results: 

1. Select Results> Result Detail to display the detailed results for the 
Transmitter or Cable Pk-Pk Jitter Measurement. 
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You can also use: 

� Compare Result button to compare results  

� Generate Report button to generate reports 

 

Figure 120: Pk-Pk Jitter results 

The following table describes the peak-to-peak jitter result options: 

Table 21: Results: Pk-Pk Jitter options and their descriptions 
Results Description 
Parameter Displays the calculated parameters for the measurement, such as 

Tbit, Acquisition Number, Pk-to-Pk jitter, and Upper Limit. 
Value Displays the values of: 

• Tbit used for calculating the peak to peak jitter limits in 
seconds  

• The number of acquisitions to create the histogram  
• The measured peak to peak jitter values in seconds 
• The maximum limit values for Jitter. The peak to peak jitter 

values above this limit indicate a Fail 
Status Displays the result status: Pass or Fail.  
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Generating Reports for Pk-Pk Jitter 

Follow these steps to generate a report for all the measurements: 

Note: Select File> Export Setup> Images> Data Format from the oscilloscope 
menu. Set the data format option to .jpg before generating a report. The report 
format does not support any other image file. Before you run the measurement, 
select Automatic IDs & Report Names to automatically generate a report. 
 

1. Select Reports> Report Generation to display the following screen: 

 

Figure 121: Generate report, report setup 

2. In the Report Setup tab, use the virtual keypad to enter the device ID. 

3. In the Description field, use the virtual keypad to enter the device 
description. 

4. If you have not yet run the measurement, and if you want the application to 
display the device ID and specify the report names automatically, select the 
Automatic IDs & Report Names box. The ID field is disabled if you select 
this option. The ID, File Name fields, and Generate button are disabled if 
this option is selected.  

5. In the Prefix field, use the virtual keypad to enter the device prefix. 

6. Select the Mode of generating the report: Manual or Automatic. If you select 
the Manual mode the Prefix field is disabled. If you select the Automatic 
mode Device ID field is disabled. 

7. The Defined field displays the predefined clock frequency values 
automatically when you define and calculate Tbit.  

8. Use the drop-down arrow in the Resolution and Refresh Rate field to set the 
values and calculate the clock frequency. The drop-down list provides the 
Resolution and Refresh Rate values according to the VESA standard. If you 
select the Select for Report box, the application displays the resolution and 
refresh rate in the generated report. 
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9. If you do not want to specify the report details, select the Generate button. 
You can do this only if you have selected the Manual mode of generating a 
report. If you want to specify the report details, perform the following steps: 

 

Figure 122: Generate report, report name 

a. In the Report Name tab, select the Browse button in the Directory field to 
browse to the directory location. 

b. In the File Name field, use the virtual keypad to enter the file name. 

c. You can use the Results option to view the results and the Compare Results 
option to compare results of two different devices. 

d. Select the Generate button to generate report an HTML report. 

Test Transmitter for Intra-Pair Skew 

Selecting and Configuring Measurements: Intra-Pair Skew 

You can select Intra-Pair skew in the following ways: 

� Measurement> Select> Transmitter>Intra-Pair Skew 

� Measurement> Select> Cable> Intra-Pair Skew 

Note: Refer to page 150 to set up the DUT before using the application for 
Transmitter Intra-Pair Skew. 

Refer to page 157 to set up the DUT before using the application for Cable Intra-
Pair Skew. 
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Follow these steps to select and configure Intra-Pair Skew: 

1. Select Measurements> Select> Transmitter/Cable> Intra-Pair Skew to 
display the following screen:  

 

Figure 123: Transmitter Intra-Pair Skew pane 

 

Figure 124: Cable Intra-Pair Skew pane 

2. You have to define Tbit: 

� If you have not calculated the Tbit value   

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  

3. Select the Configure button to display the following screen: 

 

Figure 125: Transmitter Intra-Pair Skew configuration 
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Figure 126: Cable Intra-Pair Skew configuration 

4. Set the data line (+ or −) of a data pair in the Source drop-down list. The 
available selections are: CH1 through CH4. The Source channels are 
mutually exclusive. Use two single-ended probes to connect the data pair 
(for example: Rx0+ or Rx0−) to Source1 and Source2. 

5. Set the data pair in the Pair drop down list. The available selections are: 

� RX0 

� RX1 

� RX2 

6. In the Hysteresis field, use the calculator keypad or the GP knob to enter the 
hysteresis percentage value. The range for the hysteresis is 2% to 10%. 

7. Press the Run button  to perform the test. The application displays 

the Confirm Tbit Value message box. 

8. Select Yes to display the following message box. Connect the data signals 
and press OK. 

 

Figure 127: Data signals message box 

The application calculates the Intra-Pair Skew and displays the result: Pass or 
Fail. 
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Viewing Results for Intra-Pair Skew 

Follow these steps to view Intra-Pair Skew results: 

1. Select Results> Result Detail to display the detailed and statistical results for 
the Transmitter or Cable Intra-Pair Skew Measurement. 

You can also use: 

� Compare Result button to compare results  

� Generate Report button to generate reports 

 

Figure 128: Intra-Pair Skew results 

The following table describes the intra-pair skew result options: 

Table 22: Results: Intra-Pair Skew options and their descriptions 
Results Description 

Details tab 
Parameter Displays the calculated parameters for the measurement, such as Tbit, Skew, 

and Upper Limit. 
Value Displays the values of: 

• Tbit used for calculating the intra-pair skew limits  
• The measured skew  
• The maximum limit for intra-pair skew. Values above this limit indicate a 

Fail 
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Table 22: Results: Intra-Pair Skew options and their descriptions (Cont.) 
Results Description 

Statistics tab 
Measurement Displays the selected measurement. 
Population The number of edges calculated in the acquired waveform. 
Min The minimum intra-pair skew value in the acquired waveform. 
Max The maximum intra-pair skew value in the acquired waveform. 
Mean The average of all the calculated intra-pair skew values. 
Std Dev The standard deviation of all the calculated intra-pair skew values. 
Status Displays the result status: Pass or Fail. This is common for the Details and the 

Statistics tab.  

Generating Reports for Intra-Pair Skew 

Follow these steps to generate a report for all the measurements: 

Note: Select File> Export Setup> Images> Data Format from the oscilloscope 
menu. Set the data format option to .jpg before generating a report. The report 
format does not support any other image file. Before you run the measurement, 
select Automatic IDs & Report Names to automatically generate a report. 
 

1. Select Reports> Report Generation to display the following screen: 

 

Figure 129: Generate reports, report setup 

2. In the Report Setup tab, use the virtual keypad to enter the device ID. 

3. In the Description field, use the virtual keypad to enter the device 
description. 

4. If you have not yet run the measurement, and if you want the application to 
display the device ID and specify the report names automatically, select the 
Automatic IDs & Report Names box. The ID field is disabled if you select 
this option. The ID, File Name fields, and Generate button are disabled if 
this option is selected.  

5. In the Prefix field, use the virtual keypad to enter the device prefix. 
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6. Select the Mode of generating the report: Manual or Automatic. If you select 
the Manual mode, the Prefix field is disabled. If you select the Automatic 
mode Device ID field is disabled. 

7. The Defined field displays the predefined clock frequency values 
automatically when you define and calculate Tbit.  

8. Use the drop-down arrow in the Resolution and Refresh Rate field to set the 
values and calculate the clock frequency. The drop-down list provides the 
Resolution and Refresh Rate values according to the VESA standard. If you 
select the Select for Report box, the application displays the resolution and 
refresh rate in the generated report. 

9. If you do not want to specify the report details, select the Generate button. 
You can do this only if you have selected the Manual mode of generating a 
report. If you want to specify the report details, perform the following steps: 

 

Figure 130: Generate reports, report name 

a. In the Report Name tab, select the Browse button in the Directory field to 
browse to the directory location. 

b. In the File Name field, use the virtual keypad to enter the file name. 

c. You can use the Results option to view the results and the Compare Results 
option to compare results of two different devices. 

d. Select the Generate button to generate report an HTML report.  
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Test Transmitter for Inter-Pair Skew 

Selecting and Configuring Measurements: Inter Pair Skew 

Follow these steps to select and configure Inter-Pair Skew: 

Note: Refer to page 153 to set up the DUT before using the application. 
 

1. Select Measurements> Select> Transmitter> Inter-Pair Skew to display the 
following screen.  

 

Figure 131: Inter-Pair Skew pane 

2. You have to define Tbit: 

� If you have not calculated the Tbit value   

te � If you have changed the device, resolution, refresh rate, or blanking ra
after calculating the Tbit  

3. Select the Configure button to display the following screen: 

 

Figure 132: Inter-Pair Skew configuration 
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4. Set the data line (+ or −) of the data pair in the Source1 and Source2 drop-
down list. The available selections are: CH1 through CH4. The Source 
channels are mutually exclusive. Use two single-ended probes to connect the 
data pair (for example: Rx0+ or Rx1−) to Source1 and Source2. If you have 
selected the Inter-Pair Skew option, use the drop-down arrow in the Pair1 
and Pair2 field to set the data pairs. If you select the Differential Probe box, 
the positive check boxes next to the pair fields are disabled. If you use a 
differential probe, the application calculates the time delay between two data 
pairs. If you use a single-ended probe, the application calculates the skew 
between the data lines. The available selections are:  

� RX0 

� RX1 

� RX2 

If the data pairs are positive, select the check box next to the Pair fields. You 
cannot select the same data pair in the Pair1 and Pair2 fields irrespective of 
the selected polarity (+ or −). If you select the Differential Probe box, the 
positive check boxes next to the pair fields are disabled and the application 
calculates the time delay between the two data pairs.  

5. Press the Run button . The application displays the Confirm Tbit 

Value message box. 

6. Select Yes to display the following message box. Connect the data signals 
and press OK. 

 

Figure 133: Data signals message box 

The application calculates the Inter-Pair Skew and displays the result: Pass or 
Fail. 
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Viewing Results for Inter-Pair Skew  

Follow these steps to view Inter-Pair Skew results. 

1. Select Results> Result Detail to display the detailed results for the 
Transmitter Inter-Pair Skew Measurement. 

You can also use the: 

� Compare Result button to compare results  

� Generate Report button to generate reports 

 

Figure 134: Inter-Pair Skew results 

The following table describes the inter-pair skew result options: 

Table 23: Results: Inter-Pair Skew options and their descriptions 
Results Description 

Details tab 
Parameter Displays the calculated parameters for the measurement, such as Tbit, Skew, 

and Upper Limit. 
Value Displays the values of: 

• Tbit used for calculating inter-pair skew limits in seconds  
• The measured skew in seconds 
• The maximum limit for inter-pair skew. Values above this limit indicate a 

Fail 
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Table 23: Results: Inter-Pair Skew options and their descriptions (Cont.) 
Results Description 

Statistics tab 
Measurement Displays the selected measurement. 
Population The number of edges calculated in the acquired waveform. 
Min The minimum inter-pair skew value in the acquired waveform. 
Max The maximum inter-pair skew value in the acquired waveform. 
Mean The average of all the calculated inter-pair skew values. 
Std Dev The standard deviation of all the calculated inter-pair skew values. 
Status Displays the result status: Pass or Fail. This is common for the Details and the 

Statistics tab.  

Generating Reports for Inter-Pair Skew 

Follow these steps to generate a report for all the measurements: 

Note: Select File> Export Setup> Images> Data Format from the oscilloscope 
menu. Set the data format option to .jpg before generating a report. The report 
format does not support any other image file. Before you run the measurement, 
select Automatic IDs & Report Names to automatically generate a report. 
 

1. Select Reports> Report Generation to display the following screen. 

 

Figure 135: Generate report, report setup 

2. In the Report Setup tab, use the virtual keypad to enter the device ID. 

3. In the Description field, use the virtual keypad to enter the device 
description. 

4. If you have not yet run the measurement, and if you want the application to 
display the device ID and specify the report names automatically, select the 
Automatic IDs & Report Names box. The ID field is disabled if you select 
this option. The ID, File Name fields, and Generate button are disabled if 
this option is selected.  

5. In the Prefix field, use the virtual keypad to enter the device prefix. 
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6. Select the Mode of generating the report: Manual or Automatic. If you select 
the Manual mode, the Prefix field is disabled. If you select the Automatic 
mode, Device ID field is disabled. 

7. The Defined field displays the predefined clock frequency values 
automatically when you define and calculate Tbit.  

8. Use the drop-down arrow in the Resolution and Refresh Rate field to set the 
values and calculate the clock frequency. The drop-down list provides the 
Resolution and Refresh Rate values according to the VESA standard. If you 
select the Select for Report box, the application displays the resolution and 
refresh rate in the generated report. 

9. If you do not want to specify the report details, select the Generate button. 
You can do this only if you have selected the Manual mode of generating a 
report. If you want to specify the report details, perform the following steps: 

 

Figure 136: Generate report, report name 

a. In the Report Name tab, select the Browse button in the Directory field to 
browse to the directory location. 

b. In the File Name field, use the virtual keypad to enter the file name. 

c. You can use the Results option to view the results and the Compare Results 
option to compare results of two different devices. 

d. Select the Generate button to generate report an HTML report.  
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Test Cable for Hi-Amplitude/Low-Amplitude Eye  

Select and Configure Measurements for High-Amplitude/Low-Amplitude Eye 
Diagram 

Click Measurement> Select> Cable> High-Amplitude/Low-Amplitude Eye 
Diagram. Follow these steps to select and configure High-Amplitude/Low-
Amplitude Eye Diagram: 

Note: Refer to page 162 to set up the DUT before using the application. 
 

1. Select the Measurements> Select> Cable tab to display the following screen. 
Select the High-Amplitude/Low-Amplitude Eye Diagram option. 

 

Figure 137: High-Amplitude Eye Diagram 

 

Figure 138: Low-Amplitude Eye Diagram 

2. You have to define Tbit: 

� If you have not calculated the Tbit value  

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  
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3. Select the Configure button to display the following screen: 

 

Figure 139: High-Amplitude Eye Diagram configuration 

 

Figure 140: Low-Amplitude Eye Diagram configuration 

4. In the Select Source area, from the Data drop-down list, indicate which 
channel is connected to the TPA-P fixture (at TP2) with a differential probe. 
See page 192 to learn about the TPA-P fixture at TP2 connections. The 
available selections are: Ch1 through Ch4. The application requires a 
recovered clock as an external trigger source to the oscilloscope. Set the 
trigger source in the Trigger drop-down list. The available selections are: 
Ch1 through Ch4. Data and Trigger sources are mutually exclusive. 

5. Use the drop-down arrow in the Select Pair field to set the data pair. The 
available data pairs are: 

� RX0 

� RX1 

� RX2 

Note: The data pair values appear only in the generated report. They are not 
used for any calculations. 
 

6. In the Min number of Eyes field, use the calculator keypad or the GP knob 
next to the Value field to enter the minimum number of eyes to be 
considered to place the mask. 
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7. Press the Run button  to perform the test. The application displays 

the Confirm Tbit Value message box. 

8. If the default option File> Preferences> Advanced> Cable Eye Diagram 
Test Point> Test at TP2 and TP3 is used the application does the following: 

� The application displays the following message box. Select the PRP 
pattern in the Equivalent Source Board (ESB), connect the signal from 
the TPA-P fixture and press OK. See page 192 to learn about the TPA-
P fixture connections. 

 

Figure 141: PRP message box 

� The application tests the signal with Low/High Amplitude eye mask. 

� If the signal fails, the application displays the TP2 test status and does 
not allow you to proceed further until the signal passes the test. To 
make the signal pass the test, increase or decrease the Vswing 
accordingly and run the test again. See page 193 for information on 
how to increase or decrease the Vswing. If the signal passes, you can 
view the TP2 test results and the application displays the following 
message box. 

 

Figure 142: TPA-R message box 

� Remove the TPA-P fixture at TP2 and connect the cable to the ESB 
board and the other end to TPA-R. See page 193 for information on the 
setup connections. Probe the correct data pairs from the TPA-R fixture 
and press OK. 

� The application tests the signal with the cable limit eye mask.  
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� In the TDS66604, TDS6404, TDS6604B, and TDS6804B 
oscilloscopes, if you have selected Half Clock Pattern, the application 
displays the following message box. You can select the Stop button to 
stop the process. 

 

Figure 143: Wait message box 

� The application completes the 10k acquisitions and displays the 
Monitor Eye Progress message box. Select Yes to display the Eye 
Zoom screen and No to stop running the measurement. 

 

Figure 144: Monitor eye progress message box 

Note: For expert users: If you have a standard signal that passes low or high 
amplitude mask, DVI application experts do not need to test cable at TP2 with 
low or high amplitude mask every time they run the cable measurement. For this 
purpose, we recommend that you select File> Preferences> Advanced> Cable 
Eye Diagram Test Point options. 
 

If you have selected File> Preferences> Advanced> Cable Eye Diagram Test 
Point> Test at TP2, the application performs the following sequence of steps.  

1. The application displays the message “Connect the Pseudo Random Pattern 
signal and press OK.”  

2. Select the PRP pattern in the Equivalent Source Board (ESB) and connect 
the signal from the TPA-P fixture and press OK. 
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Figure 145: PRP message box 

The application tests the signal with Low/High Amplitude eye mask and displays 
the results. 

If you have selected File> Preferences> Advanced> Cable Eye Diagram Test 
Point> Test at TP3. 

1. The application displays the message, "Connect TPA-R signal and press 
OK". 

2. Connect the cable to the ESB board and the other end to TPA-R. Probe the 
correct data pairs from TPA-R and press OK. 

 

Figure 146: TPA-R signal message box 

The application tests the signal with the cable limit eye mask and displays the 
results. 

Note: If you have selected File> Preferences> Advanced> Cable Eye Diagram 
Test Point> Test at TP2 & TP3, you can generate reports only when the TP3 
result is available (Pass or Fail). If you try to generate a report, the application 
displays the following error message box 
 

 

Figure 147: Test not completed message box 
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Viewing Results for High-Amplitude/Low-Amplitude Eye Diagram 

Follow these steps to view High-Amplitude/Low-Amplitude Eye Diagram 
results: 

1. Select Results> Result Detail to display the detailed results for the Cable 
High/Low-Amplitude Measurement. 

You can also use the Compare Result button to compare results and 
Generate Report button to generate reports 

 

Figure 148: High-Amplitude Eye Diagram results 
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Figure 149: Low-Amplitude Eye Diagram results 

The following table describes the high/low amplitude eye diagram result options: 

Table 24: Results: High-Amplitude/Low-Amplitude Eye Diagram options and their 
descriptions 
 Results  Description 
 Parameter Displays the calculated parameters for the measurement, such as Tbit, 

Acquisition Number, Vswing, Worst Tbit, Overshoot, Undershoot, Vopen, 
Hopen, and number of Hit Counts. 

 Value Displays the values of: 
• Tbit used to calculate the coordinates of the eye mask 
• The number of acquisitions to create the eye diagram 
• Calculated Vswing in volts  
• Calculated Worst Tbit which is the minimum horizontal opening or time in 

the displayed eye in seconds  
• Calculated Overshoot and Undershoot of the eye diagram  
• Vopen in volts and Hopen in seconds  
• The number of Hit counts on the eye mask 

Status Displays the result status: Pass or Fail. 
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Generating Reports for High-Amplitude/Low-Amplitude Eye Diagram 

Follow these steps to generate a report for all the measurements: 

Note: Select File> Export Setup> Images> Data Format from the oscilloscope 
menu. Set the data format option to .jpg before generating a report. The report 
format does not support any other image file. Before you run the measurement, 
select Automatic IDs & Report Names to automatically generate a report. 
 

1. Select Reports> Report Generation to display the following screen. 

 

Figure 150: Generate report, report setup 

2. In the Report Setup tab, use the virtual keypad to enter the device ID. 

3. In the Description field, use the virtual keypad to enter the device 
description. 

4. If you have not yet run the measurement, and if you want the application to 
display the device ID and specify the report names automatically, select the 
Automatic IDs & Report Names box. The ID field is disabled if you select 
this option. The ID, File Name fields, and Generate button are disabled if 
this option is selected.  

5. In the Prefix field, use the virtual keypad to enter the device prefix. 

6. Select the Mode of generating the report: Manual or Automatic. If you select 
the Manual mode, the Prefix field is disabled. If you select the Automatic 
mode, Device ID field is disabled. 

7. The Defined field displays the predefined clock frequency values 
automatically when you define and calculate Tbit.  

8. Use the drop-down arrow in the Resolution and Refresh Rate field to set the 
values and calculate the clock frequency. The drop-down list provides the 
Resolution and Refresh Rate values according to the VESA standard. If you 
select the Select for Report box, the application displays the resolution and 
refresh rate in the generated report. 
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9. If you do not want to specify the report details, select the Generate button. 
You can do this only if you have selected the Manual mode of generating a 
report. If you want to specify the report details, perform the following steps: 

 

Figure 151: Generate report, report name 

a. In the Report Name tab, select the Browse button in the Directory field to 
browse to the directory location. 

b. In the File Name field, use the virtual keypad to enter the file name. 

c. You can use the Results option to view the results and the Compare Results 
option to compare results of two different devices. 

d. Select the Generate button to generate report an HTML report. 

Test Cable for Pk-Pk Jitter 

Selecting and Configuring Measurements for Pk-Pk Jitter 

You can select Pk-Pk Jitter in the following ways: 

� Measurement> Select> Transmitter> Pk-Pk Jitter 

� Measurement> Select> Cable> Pk-Pk Jitter 

Note: Refer to page 147 to set up the DUT before using the application for 
Transmitter Pk-Pk Jitter. 

Refer to page 156 to set up the DUT before using the application for Cable Pk-
Pk Jitter. 

To get appropriate results in Pk-Pk Jitter measurements, from the oscilloscope 
menu bar, select Measure> Waveform Histograms> Adjust Histogram Box 
Limits.  
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Follow these steps to select and configure Pk-Pk Jitter: 

1. Select Measurements> Select> Transmitter/Cable> Pk-Pk Jitter to display 
the screen:  

 

Figure 152: Transmitter Pk-Pk Jitter pane 

 

Figure 153: Cable Pk-Pk Jitter pane 

2. You have to define Tbit: 

� If you have not calculated the Tbit value   

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  

3. Select the Configure button to display the following screen: 

 

Figure 154: Transmitter Pk-Pk Jitter configuration 

TDSDVI-DVI Compliance Test Solution           111 



Operating Basics 
 

 

Figure 155: Cable Pk-Pk Jitter configuration 

4. Select the transmitted differential clock source from the Tx Clock drop-
down list. The available selections are: CH1 through CH4. The application 
requires a CRU (Clock Recovery Unit) to trigger the oscilloscope. Set the 
trigger source channel from the Trigger drop-down list. Data and Trigger 
source are mutually exclusive.  

5. Press the Run button  to perform the test. The application displays 

the Confirm Tbit Value message box. 

6. Confirm the Tbit value to display the following message box. Connect the 
clock signals and press OK. 

 

Figure 156: Clock signals message box 

The application calculates the Pk-PK Jitter and displays the result: Pass or Fail. 

Note: For more in-depth analysis on Jitter, use the TDSJIT3 Package. 
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If the signal is unstable, the application cannot place the histogram at the second 
rising edge of the clock signal, then the application displays the following 
message box: 

 

Figure 157: Holdoff message box 

To adjust the Trigger Holdoff time,  

1. Select Trig> Holdoff from the oscilloscope interface. 

2. Use the GP knob on the oscilloscope panel to adjust the trigger hold off 
time. 

3. After stabilizing the signal, press the APP button in the oscilloscope 
interface to display the application. 

4. Press OK in Figure 157 Holdoff message box to continue the peak-to-peak 
jitter measurement and Cancel to stop running the measurement. 

 

Figure 158: Oscilloscope interface 
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Viewing Results for Pk-Pk Jitter 

Follow these steps to view Pk-Pk Jitter results: 

1. Select Results> Result Detail to display the detailed results for the Cable Pk-
Pk Jitter measurement. 

You can also use the: 

� Compare Result button to compare results  

� Generate Report button to generate reports 

 

Figure 159: Rise and Fall Time results-Details 

The following table describes the pk-pk jitter result options: 

Table 25: Results: Pk-Pk Jitter options and their descriptions 
Results Description 
Parameters Displays the calculated parameters for the measurement, such as Tbit, 

Acquisition Number, Pk-to-Pk, and Upper Limit. 
Value Displays the values of: 

• Tbit used for calculating the peak to peak jitter limit in seconds 
• The number of acquisitions to create the histogram 
• The measured peak to peak jitter in seconds 
• The maximum limit for Jitter. The values above this limit indicate a Fail 

Status Displays the result status: Pass or Fail. 

114                                       TDSDVI-DVI Compliance Test Solution 



Operating Basics 
 

Generating Reports for Pk-Pk Jitter 

Follow these steps to generate a report for all the measurements: 

Note: Select File> Export Setup> Images> Data Format from the oscilloscope 
menu. Set the data format option to .jpg before generating a report. The report 
format does not support any other image file. Before you run the measurement, 
select Automatic IDs & Report Names to automatically generate a report. 
 

1. Select Reports> Report Generation to display the following screen: 

 

Figure 160: Generate report, report setup 

2. In the Report Setup tab, use the virtual keypad to enter the device ID. 

3. In the Description field, use the virtual keypad to enter the device 
description. 

4. If you have not yet run the measurement, and if you want the application to 
display the device ID and specify the report names automatically, select the 
Automatic IDs & Report Names box. The ID field is disabled if you select 
this option. The ID, File Name fields, and Generate button are disabled if 
this option is selected.  

5. In the Prefix field, use the virtual keypad to enter the device prefix. 

6. Select the Mode of generating the report: Manual or Automatic. If you select 
the Manual mode, the Prefix field is disabled. If you select the Automatic 
mode, Device ID field is disabled. 

7. The Defined field displays the predefined clock frequency values 
automatically when you define and calculate Tbit.  

8. Use the drop-down arrow in the Resolution and Refresh Rate field to set the 
values and calculate the clock frequency. The drop-down list provides the 
Resolution and Refresh Rate values according to the VESA standard. If you 
select the Select for Report box, the application displays the resolution and 
refresh rate in the generated report. 
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9. If you do not want to specify the report details, select the Generate button. 
You can do this only if you have selected the Manual mode of generating a 
report. If you want to specify the report details, perform the following steps: 

 

Figure 161: Generate report, report name 

a. In the Report Name tab, select the Browse button in the Directory field to 
browse to the directory location. 

b. In the File Name field, use the virtual keypad to enter the file name. 

c. You can use the Results option to view the results and the Compare Results 
option to compare results of two different devices. 

d. Select the Generate button to generate report an HTML report.  

Test Cable for Intra-Pair Skew 
Selecting and Configuring Measurements: Intra-Pair Skew 

You can select the Intra-Pair skew in the following ways: 

� Measurement> Select> Transmitter>Intra-Pair Skew 

� Measurement> Select> Cable> Intra-Pair Skew 

Note: Refer to page 150 to set up the DUT before using the application for 
Transmitter Intra-Pair Skew. 
Refer to page 157 to set up the DUT before using the application for Cable Intra-
Pair Skew. 
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Follow these steps to select and configure Intra-Pair Skew: 

1. Select Measurements> Select> Transmitter/Cable> Intra-Pair Skew to 
display the following screen.  

 

Figure 162: Transmitter Intra-Pair Skew pane 

 

Figure 163: Cable Intra-Pair Skew pane 

2. You have to define Tbit: 

� If you have not calculated the Tbit value  

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  

3. Select the Configure button to display the following screen: 

 

Figure 164: Transmitter Intra-Pair Skew configuration 
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Figure 165: Cable Intra-Pair Skew configuration 

4. Set the data line (+ or −) of a data pair in the Source drop-down list. The 
available selections are: CH1 through CH4. The Source channels are 
mutually exclusive. Use two single-ended probes to connect the data pair 
(for example: Rx0+ or Rx0−) to Source1 and Source2. 

5. Set the data pair in the Pair drop down list. The available selections are: 

� RX0 

� RX1 

� RX2 

6. In the Hysteresis field, use the calculator keypad or the GP knob to enter the 
hysteresis percentage value. The range for the hysteresis is 2% to 10%. 

7. Press the Run button  to perform the test. The application displays 

the Confirm Tbit Value message box. 

8. Select Yes to display the following message box. Connect the data signals 
and press OK. 

 

Figure 166: Data signals message box 

The application calculates the Intra-Pair Skew and displays the result: Pass or 
Fail. 
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Viewing Results for Intra-Pair Skew  

Follow these steps to view Intra-Pair Skew results: 

1. Select Results> Result Detail to display the detailed results for the Cable 
Intra-Pair Skew measurement. 

You can also use the: 

� Compare Result button to compare results  

� Generate Report button to generate reports 

 

Figure 167: Cable Intra-Pair Skew results 

The following table describes the intra-pair skew result options: 

Table 26: Results: Intra-Pair Skew options and their descriptions 
Results Description 

Details tab 
Parameter Displays the calculated parameters for the measurement, such as Tbit, Skew, 

and Upper Limit. 
Values Displays the values of: 

• Tbit used for calculating the intra-pair skew limits in seconds  
• The measured skew in seconds 
• The maximum limit for Intra-Pair Skew. Values above this limit indicate a 

Fail 
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Table 26: Results: Intra-Pair Skew options and their descriptions (Cont.) 
Results Description 

Statistics tab 
Measurement Displays the selected measurement. 
Population The number of edges calculated in the acquired waveform. 
Min The minimum intra-pair skew value in the acquired waveform. 
Max The maximum intra-pair skew value in the acquired waveform. 
Mean The average of all the calculated intra-pair skew values. 
Std Dev The standard deviation of all the calculated intra-pair skew values. 
Status Displays the result status: Pass or Fail. This is common for the Details and the 

Statistics tab. 

Generating Reports for Intra-Pair Skew  

Follow these steps to generate a report for all the measurements: 

Note: Select File> Export Setup> Images> Data Format from the oscilloscope 
menu. Set the data format option to .jpg before generating a report. The report 
format does not support any other image file. Before you run the measurement, 
select Automatic IDs & Report Names to automatically generate a report. 
 

1. Select Reports> Report Generation to display the following screen: 

 

Figure 168: Generate report, report setup 

2. In the Report Setup tab, use the virtual keypad to enter the device ID. 

3. In the Description field, use the virtual keypad to enter the device 
description. 

4. If you have not yet run the measurement, and if you want the application to 
display the device ID and specify the report names automatically, select the 
Automatic IDs & Report Names box. The ID field is disabled if you select 
this option. The ID, File Name fields, and Generate button are disabled if 
this option is selected.  

5. In the Prefix field, use the virtual keypad to enter the device prefix. 
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6. Select the Mode of generating the report: Manual or Automatic. If you select 
the Manual mode, the Prefix field is disabled. If you select the Automatic 
mode, Device ID field is disabled. 

7. The Defined field displays the predefined clock frequency values 
automatically when you define and calculate Tbit.  

8. Use the drop-down arrow in the Resolution and Refresh Rate field to set the 
values and calculate the clock frequency. The drop-down list provides the 
Resolution and Refresh Rate values according to the VESA standard. If you 
select the Select for Report box, the application displays the resolution and 
refresh rate in the generated report. 

9. If you do not want to specify the report details, select the Generate button. 
You can do this only if you have selected the Manual mode of generating a 
report. If you want to specify the report details, perform the following steps: 

 

Figure 169: Generate report, report name 

a. In the Report Name tab, select the Browse button in the Directory field to 
browse to the directory location. 

b. In the File Name field, use the virtual keypad to enter the file name. 

c. You can use the Results option to view the results and the Compare Results 
option to compare results of two different devices. 

d. Select the Generate button to generate report an HTML report 
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Test Cable for Inter-Pair Skew 

Selecting and Configuring Measurements for Inter-Pair Skew 

Follow these steps to select and configure Inter-Pair Skew: 

Note: Refer to page 160 to set up the DUT before using the application. 
 

1. Select Measurements> Select> Cable> Inter-Pair Skew to display the 
following screen: 

 

Figure 170: Inter-Pair Skew pane 

2. You have to define Tbit: 

� If you have not calculated the Tbit value  

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  

3. Select the Configure button to display the following screen: 

 

Figure 171: Inter-Pair Skew configuration 
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4. In the Select Source pane, select the channel connected in the TPA-P fixture 
with a differential probe from the Source1 and Source2 field drop down list. 
The available selections are: CH1 through CH4. The application requires a 
recovered clock as an external trigger source to the oscilloscope. If you 
select the Differential Probe box, the positive check boxes next to the pair 
fields are disabled. Set the data pair in the Select Pair drop down list to set 
the data pair. The available selections are:  

� RX0 

� RX1 

� RX2 

If the data line is positive, select the check box next to the Pair1 and Pair2 
fields. You cannot select the same data pair in the Pair1 and Pair2 fields 
regardless of the polarity (+ or −). 

5. Press the Run button  to perform the test. The application displays 

the Confirm Tbit Value message box. 

6. Select Yes to display the following message box. Connect the data signals 
and press OK. 

 

Figure 172: Data signals message box 

The application calculates the Inter-Pair Skew and displays the result: Pass or 
Fail. 

Viewing Results-Inter-Pair Skew 

Follow these steps to view Inter-Pair Skew results: 

1. Select Results> Result Detail to display the detailed results for the Cable 
Inter-Pair Skew measurement. 

You can also use the: 

� Compare Result button to compare results  

� Generate Report button to generate reports 
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Figure 173: Inter-Pair Skew results 

The following table describes the inter-pair skew result options: 

Table 27: Results: Inter-Pair Skew options and their descriptions 
Results Description 

Details tab 
Parameter Displays the calculated parameters for the measurement, such as Tbit, Skew, 

and Upper Limit. 
Value Displays the values of 

• Tbit used for calculating the inter-pair skew limits in seconds  
• The measured skew in seconds 
• The maximum limit for inter-pair skew. Values above this limit indicate a 

Fail 
Statistics tab 
Measurement Displays the selected measurement. 
Population The number of edges calculated in the acquired waveform. 
Min The minimum inter-pair skew values in the acquired waveform. 
Max The maximum inter-pair skew values in the acquired waveform. 
Mean The average of all the calculated inter-pair skew values. 
Std Dev The standard deviation of all the calculated inter-pair skew values. 
Status Displays the result status: Pass or Fail. This is common to the Details and the 

Statistics tab. 
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Generating Reports for Inter-Pair Skew 

Follow these steps to generate a report for all the measurements: 

Note: Select File> Export Setup> Images> Data Format from the oscilloscope 
menu. Set the data format option to .jpg before generating a report. The report 
format does not support any other image file. Before you run the measurement, 
select Automatic IDs & Report Names to automatically generate a report. 
 

1. Select Reports> Report Generation to display the following screen. 

 

Figure 174: Generating reports, report setup 

2. In the Report Setup tab, use the virtual keypad to enter the device ID. 

3. In the Description field, use the virtual keypad to enter the device 
description. 

4. If you have not yet run the measurement, and if you want the application to 
display the device ID and specify the report names automatically, select the 
Automatic IDs & Report Names box. The ID field is disabled if you select 
this option. The ID, File Name fields, and Generate button are disabled if 
this option is selected.  

5. In the Prefix field, use the virtual keypad to enter the device prefix. 

6. Select the Mode of generating the report: Manual or Automatic. If you select 
the Manual mode, the Prefix field is disabled. If you select the Automatic 
mode, Device ID field is disabled. 

7. The Defined field displays the predefined clock frequency values 
automatically when you define and calculate Tbit.  

8. Use the drop-down arrow in the Resolution and Refresh Rate field to set the 
values and calculate the clock frequency. The drop-down list provides the 
Resolution and Refresh Rate values according to the VESA standard. If you 
select the Select for Report box, the application displays the resolution and 
refresh rate in the generated report. 
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9. If you do not want to specify the report details, select the Generate button. 
You can do this only if you have selected the Manual mode of generating a 
report. If you want to specify the report details, perform the following steps: 

 

Figure 175: Generating reports, report name 

a. In the Report Name tab, select the Browse button in the Directory field to 
browse to the directory location. 

b. In the File Name field, use the virtual keypad to enter the file name. 

c. You can use the Results option to view the results and the Compare Results 
option to compare results of two different devices. 

d. Select the Generate button to generate report an HTML report.  

Test Receiver for High-Amplitude/Low-Amplitude Eye Diagram 

Selecting and Configuring Measurements: High-Amplitude/Low-Amplitude Eye 
Diagram 

Note: Refer to page 167 to set up the DUT before using the application. 
 

1. Select the Measurements> Select> Receiver tab to display the following 
screen. Select High-Amplitude/Low-Amplitude Eye Diagram. 

 

Figure 176: Receiver High-Amplitude Eye Diagram pane 

126                                       TDSDVI-DVI Compliance Test Solution 



Operating Basics 
 

 

Figure 177: Receiver Low-Amplitude Eye Diagram pane 

2. You have to define Tbit: 

� If you have not calculated the Tbit value  

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  

3. Select the Configure button to display the following screen: 

 

Figure 178: High-Amplitude configuration 

 

Figure 179: Low-Amplitude configuration 

4. In the Select Source pane, select the data source channel from the Data 
drop-down list. The available selections are: CH1 through CH4. The 
application requires a recovered clock as an external trigger source to the 
oscilloscope. Use the drop-down arrow in the Trigger field to set the trigger 
source channel. The available selections are: CH1 through CH4. The Data 
and Trigger fields identify the data source and the external clock source. 
You cannot set the same channel for Data and Trigger source. 
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5. Use the drop-down arrow in the Select Pair field to set the data pair. The 
available data pairs are: Rx0, Rx1 and Rx2. 

Note: The data pair values appear only in the generated report. They are not 
used for any calculations. 
 

6. In the Number of Eyes field, use the calculator keypad  or the GP knob 
next to the Value field to set the minimum number of eyes required to 
perform Receiver Eye measurement. After you set the minimum number of 
eyes, the worst eye is placed in the eye mask.  

7. Press the Run button  to perform the test. The application displays 

the Confirm Tbit Value message box. 

8. If you are sure you have defined the Tbit value, the application displays the 
following message box. If you select OK, the application deletes the 
previous Ref1 waveform and stores the current eye diagram results in the 
Ref1 waveform.  

 

Figure 180: Ref1 message box 

This message box will appear only if you have selected File> Preferences> 
General> Ref waveform deletion prompt for Eye box. 

9. Select OK to display the following message box. Select the PRP pattern in 
the Equivalent Source Board (ESB) and connect the signal from the TPA-R 
fixture and press OK. See page 192 for information about TPA-P fixture 
connections. 

 

Figure 181: PRP message box 

128                                       TDSDVI-DVI Compliance Test Solution 



Operating Basics 
 

10. If you are using a TDS6604, TDS6404, TDS6604B, or TDS6804B 
oscilloscope: 

a. The application displays the Monitor Eye Progress message box. 

 

Figure 182: Monitor eye progress message box 

b. Select Yes to display the Eye Zoom screen and No to display the results 
pane and wait until the application displays the results. 

11. If you have selected File> Preferences> General> Use cursors for Eye, RT 
and FT Testing, see page 191 for further information on what the application 
does. 

The application tests the signal with the receiver low/high amplitude eye mask 
and displays the results. 

Viewing Results for High-Amplitude/Low-Amplitude Eye Diagram 

Follow these steps to view High-Amplitude/Low-Amplitude Eye Diagram 
results: 

1. Select Results> Result Detail to display the detailed results for the Receiver 
High-Amplitude/Low-Amplitude Eye Diagram measurement. 

You can also use the: 

� Compare Result button to compare results  

� Eye Zoom button to view the zoomed eye  

� Generate Report button to generate reports 
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Figure 183: High-Amplitude Eye Diagram results 

 

Figure 184: Low-Amplitude Eye diagram results 
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The following table describes the high/low amplitude eye diagram result options: 

Table 28: Results: High-Amplitude/Low Amplitude Eye Diagram options and 
their descriptions 
Results Description 
Parameter Displays the calculated parameters for the measurement, such as Tbit, 

Acquisition Number, Vswing, Worst Tbit, Overshoot, Undershoot, Vopen, 
Hopen, and Hit Counts. 

Value Displays the values of: 
• Tbit used for calculating the coordinates of the eye mask 
• Calculated Worst Tbit in the displayed eyes in seconds  
• The number of acquisitions to create the eye diagram 
• Calculated Vswing in volts  
• Calculated Overshoot, Undershoot of the eye diagram  
• Vopen in volts and Hopen in seconds  
• The number of Hit counts on the eye mask 

Status Displays the result status: Pass or Fail. 

Generating Reports for High-Amplitude/Low-Amplitude Eye Diagram 

Follow these steps to generate a report for all the measurements: 

Note: Select File> Export Setup> Images> Data Format from the oscilloscope 
menu. Set the data format option to .jpg before generating a report. The report 
format does not support any other image file. Before you run the measurement, 
select Automatic IDs & Report Names to automatically generate a report. 
 

1. Select Reports> Report Generation to display the following screen: 

 

Figure 185: Generating reports, report setup 

2. In the Report Setup tab, use the virtual keypad to enter the device ID. 

3. In the Description field, use the virtual keypad to enter the device 
description. 
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4. If you have not yet run the measurement, and if you want the application to 
display the device ID and specify the report names automatically, select the 
Automatic IDs & Report Names box. The ID field is disabled if you select 
this option. The ID, File Name fields, and Generate button are disabled if 
this option is selected.  

5. In the Prefix field, use the virtual keypad to enter the device prefix. 

6. Select the Mode of generating the report: Manual or Automatic. If you select 
the Manual mode, the Prefix field is disabled. If you select the Automatic 
mode, Device ID field is disabled. 

7. The Defined field displays the predefined clock frequency values 
automatically when you define and calculate Tbit.  

8. Use the drop-down arrow in the Resolution and Refresh Rate field to set the 
values and calculate the clock frequency. The drop-down list provides the 
Resolution and Refresh Rate values according to the VESA standard. If you 
select the Select for Report box, the application displays the resolution and 
refresh rate in the generated report. 

9. If you do not want to specify the report details, select the Generate button. 
You can do this only if you have selected the Manual mode of generating a 
report. If you want to specify the report details, perform the following steps: 

 

Figure 186: Generating reports, report name 

a. In the Report Name tab, select the Browse button in the Directory field to 
browse to the directory location. 

b. In the File Name field, use the virtual keypad to enter the file name. 

c. You can use the Results option to view the results and the Compare Results 
option to compare results of two different devices. 

d. Select the Generate button to generate report an HTML report.  
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Save and Recall Setups 

Recall Default Setup  

To recall the default application settings: 

1. Select File> Recall default. You will see the message, "Recall default will 
change the existing settings and restore the default settings. Do you wish to 
continue?" 

2. Select Yes to change the current settings to the default settings. Select No to 
retain the current settings. 

Save a Setup 

To save the application and oscilloscope settings to a setup file: 

1. Select File> Save. 

2. Select the directory. 

3. Select or enter a file name with an .ini extension. If the file name does not 
have an ".ini" extension, the application adds an .ini extension. If you give 
an invalid extension, the application displays an error message "File name 
has an invalid extension". 

4. Select Save. 

Note: The application also saves the oscilloscope settings to a ".set" file when 
you save the settings. Both the application ".ini" file and oscilloscope ".set" file 
has the same file name. While saving the settings, the application checks for the 
disk space available. 

Recall a Setup 

To recall the application and oscilloscope settings from a saved setup file, follow 
these steps: 

1. Select File> Recall. 

2. Select the directory. 

3. Select or enter a file name with an .ini extension. If the file name does not 
have an .ini extension, the application displays an error message "File does 
not exist." 

4. Select Open to recall the specified settings. 

5. If the settings are recalled successfully, the application displays a message 
"File recalled successfully". If the settings are not recalled successfully, the 
application displays an error message. 

TDSDVI-DVI Compliance Test Solution           133 



Operating Basics 
 

Note: The application also recalls the oscilloscope setup from a ".set" file when 
you recall its setup.  

Recall a Recently Recalled Setup  

To recall the recent file settings, follow these steps. 

1. Select File> Recently Recalled to display the last four recalled files. 

2. If you recall the settings from any file in the recently recalled file list and the 
file already exists, the application displays a message "Do you want to recall 
the settings?". If you select Yes, the application recalls the settings. If you 
select No, the oscilloscope settings or the existing settings are retained. 

3. The application reorders the list of recently recalled files. For example, if 
the order is file1, file2, file3 and file4, then, on selecting file3, the display 
order changes to file3, file1, file2, and file4. 

Recall a Recently Saved Setup 

To overwrite the settings of a file from the recently saved list, follow these steps. 

1. Select File> Recently Saved to display the last four saved files. 

2. If you save the settings in any one file from the recently saved file list and 
the file already exists, the application prompts a message to overwrite the 
settings. If you select Yes, the application overwrites the settings. If you 
select No, the settings are retained. 

3. The application reorders the list of recently recalled files. For example, if 
the order is file1, file2, file3 and file4, then, on selecting file3, the display 
order changes to file3, file1, file2, and file4. 

Note: The application will not reorder the file list when the settings are saved to 
a file that appears as a first menu item in the recently saved file list. 

Set Cursors for Eye, RT and FT Testing 

The application automatically enables the oscilloscope's cursors relevant to each 
measurement. By default, the cursor option is not selected. 

Note: Rise and Fall Time measurement uses cursors to calculate Vswing. In Eye 
Diagram measurement, you can use cursors to calculate Vswing and select the 
worst eye opening. 

If you select File> Preferences> Use cursors for Eye, RT and FT testing: 

� To calculate Vswing, the application enables the horizontal cursors in the 
oscilloscope and displays the following message box. Place the cursors on 
the Vswing high and Vswing low of the eye diagram for the Rise and Fall 
Time and Eye Diagram measurement. Select OK to calculate Vswing. 
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Figure 187: Message box 

� To select the worst eye opening, the application enables the vertical cursors. 
Place the cursors at the crossover points of the worst eye opening for the 
Eye Diagram measurement. Select OK to set the worst eye. The application 
places the mask on the worst eye opening. 

 

Figure 188: Message box 
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Application Examples 

This section presents many application examples.  

To run the application examples, install and enable the application on the 
oscilloscope, connect the probes to the device under test, and select and configure 
a measurement. To install the application, refer to Installation Procedures on 
page 141. For more information on compatible probes, refer to Compatibility on 
page 7 and Accessories on page 8.  

Tbit 

Specifying the Equipment: Define Tbit 

You need the following equipment to set up the application and calculate Tbit: 

� CSA7404, CSA7404B, TDS7404, TDS7404B, TDS7254, TDS7524B, 
TDS7704B, TDS6604, TDS6404, TDS6604B, TDS6804B, DPO7354, and  
DPO/DSA70000 series oscilloscope with recommended firmware version 

� P7330, P7350 or P6330 (needs TCA-BNC adapter) differential probes  

� TPA-P or TPA-R test fixture 

� Device Under Test 
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Equipment Setup: Define Tbit 

To set up a device to measure Tbit, follow these steps: 

 

Figure 189: DVI monitor setup 

1. Connect the DVI monitor to the DVI port of the AGP ADD Card in the PC. 
Set the required screen resolution and the refresh rate. Set the host computer 
to run with a Half Clock Pattern to conduct the test. For information on how 
to set the host computer to run with a Half Clock Pattern to conduct the test, 
see page 191. 

2. Remove the DVI monitor and attach the TPA-P fixture to the DVI port of 
the DUT. 
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Figure 190: TPA-P fixture to the transmitter setup 

3. Connect a P7350, P7330 or P6330 probe from any one of the four channels 
of the oscilloscope to the transmitted clock (Rxc+/−) on the TPA-P fixture. 
The following figure shows the test point for Rxc+/−.  

 

Figure 191: TPA-P test points 
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4. Configure the measurement and run the application. 

Note: We recommend that you calculate the Tbit with the differential transmitted 
clock rather than defining Tbit values yourself. You need to calculate Tbit only 
once. This value will be retained for further measurements. If the device, 
resolution, blanking rate, or refresh rate changes, you have to recalculate Tbit. 

Transmitter Eye Diagram 

Specifying the Equipment: Transmitter Eye Diagram 

You need the following equipment to set up the application and test Eye Diagram 
in a Transmitter: 

� CSA7404, CSA7404B, TDS7404, TDS7404B, TDS7254, TDS7524B, 
TDS7704B, TDS6604, TDS6404, TDS6604B, TDS6804B, DPO7354, and  
DPO/DSA70000 series oscilloscope with recommended firmware version 

� P7330, P7350 or P6330 (needs TCA-BNC adapter) differential probes  

� SMA cable 

� TPA-P test fixture 

� Device Under Test 
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Equipment Setup-Transmitter: Eye Diagram 

To set up a Transmitter to measure Eye Diagram, follow these steps: 

 

Figure 192: DVI monitor setup 

1. Connect the DVI monitor to the DVI port of the AGP ADD Card of the PC. 
Set the required screen resolution and the refresh rate. Set the host computer 
to run with the Half Clock Pattern to conduct the test. For information on 
how to set the host computer to run with a Half Clock Pattern to conduct the 
test, see page 191. 

2. Remove the DVI monitor and attach the TPA-P fixture to the DVI port of 
the DUT. 
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Figure 193: TPA-P fixture to the transmitter setup 

3. Using the application define Tbit before selecting a measurement. 

4. Connect a P7350, P7330 or P6330 probe from any one of the four channels 
of the oscilloscope to one of the data pairs (Rx0+/−, Rx1+/−, Rx2+/−) of the 
TPA-P fixture. Figure 194 displays the Rx0 test point. As specified by the 
DDWG specifications, perform the Transmitter Eye Diagram test in Rx1 
and Rx2 test points shown in the Figure 194. 

5. Connect the SMA cable to either one of the remaining three channels on the 
oscilloscope to the PLL Clock on the TPA-P fixture. Figure 194 shows the 
PLL Clock test point. 

Note: You can refer the TPA-P test points for Rx1 and Rx2 data pairs on  
page 194. 
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Figure 194: TPA-P fixture test points 

6. Configure the application and run the test in the application. 

Transmitter Rise and Fall Time 

Specifying the Equipment: Transmitter Rise and Fall Time 

You need the following equipment to set up the application and test Rise and Fall 
Time in a Transmitter: 

� CSA7404, CSA7404B, TDS7404, TDS7404B, TDS7254, TDS7524B, 
TDS7704B, TDS6604, TDS6404, TDS6604B, TDS6804B, DPO7354, and  
DPO/DSA70000 series oscilloscope with recommended firmware version 

� P7350, P7330, P6330 (needs TCA-BNC adapter) differential probes 

� SMA cable 

� TPA-P test fixture 

� Device Under Test 

TDSDVI-DVI Compliance Test Solution           143 



Application Examples 
 

Equipment Setup: Transmitter- Rise and Fall Time 

To set up a Transmitter to measure Rise Time/Fall Time follow these steps: 

 

 

Figure 195: DVI monitor setup 

1. Connect the DVI monitor to the DVI port of the AGP ADD Card in the PC. 
Set the host computer to run with the Half Clock Pattern to conduct the test. 
For information on how to set the host computer to run with a Half Clock 
Pattern to conduct the test, see page 191. 

2. Remove the DVI monitor and attach the TPA-P fixture to the DVI port of 
the DUT (AGP ADD card with Tx chip). 
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Figure 196: TPA-P fixture to the transmitter setup 

3. Using the application, define Tbit before selecting a measurement. 

4. Connect a P7350, P7330, or P6330 probe from any one of the four channels 
of the oscilloscope to either of the data pairs (Rx0+/−, Rx1+/−, Rx2+/−) on 
the TPA-P fixture. Figure 197 shows the Rx0 test point. Similarly, perform 
the tests in Rx1 and Rx2. 

5. Connect the SMA cable from the remaining three channels on the 
oscilloscope to the SMA connector (PLL Clock) on the TPA-P fixture. 
Figure 197 shows the PLL Clock test point. 

Note: You can refer to the TPA-P test points for Rx1 and Rx2 data pairs on 
page194. 
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Figure 197: TPA-P test points 

6. Configure the application and run the test in the application. 

Transmitter Pk-Pk Jitter 

Specifying the Equipment: Transmitter PK-Pk Jitter 

You need the following equipment to set up the application and test Pk-Pk Jitter 
in a Transmitter: 

� CSA7404, CSA7404B, TDS7404, TDS7404B, TDS7254, TDS7524B, 
TDS7704B, TDS6604, TDS6404, TDS6604B, TDS6804B, DPO7354, and  
DPO/DSA70000 series oscilloscope with recommended firmware version  

� P7330, P7350 differential probe 

� P6330 differential probe (needs TCA-BNC adapter)  

� SMA cable 

� TPA-P test fixture  

� Device Under Test 
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Equipment Setup: Transmitter-Pk-Pk Jitter 

To set up a Transmitter to measure Jitter follow these steps: 

 

Figure 198: DVI monitor setup 

1. Connect the DVI monitor to the DVI port of the AGP ADD Card of the PC. 
Set the required screen resolution and the refresh rate. Set the host computer 
to run with Half Clock pattern to conduct the test. For information on how to 
set the host computer to run with a Half Clock Pattern to conduct the test, 
see page 191. 

2. Remove the DVI monitor and attach the TPA-P fixture to the DVI port of 
the DUT. 
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Figure 199: TPA-P fixture to the transmitter setup 

3. Using the application, define Tbit before selecting a measurement. 

4. Connect a P7350, P7330 or P6330 probe from any one of the four channels 
of the oscilloscope to the transmitted clock (Rxc+/−) on the TPA-P fixture. 
Figure 200 shows the Rxc+/− test point.  

5. Connect the SMA cable from the remaining three channels on the 
oscilloscope to the SMA connector (PLL Clock) on the TPA-P fixture. 
Figure 200 shows the PLL Clock trigger source test point. 
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Figure 200: TPA-P test points 

6. Configure the measurement and run the application. 

Transmitter Intra-Pair Skew 

Specifying the Equipment: Transmitter-Intra-Pair Skew 

You need the following equipment to set up the application and test Intra-Pair 
Skew in a Transmitter: 

� CSA7404, CSA7404B, TDS7404, TDS7404B, TDS7254, TDS7524B, 
TDS7704B, TDS6604, TDS6404, TDS6604B, TDS6804B, DPO7354, and  
DPO/DSA70000 series oscilloscope with recommended firmware version  

� P7240 or P6249 single-ended probe (two numbers) 

� SMA cable 

� TPA-P fixture 

� Device Under Test 

TDSDVI-DVI Compliance Test Solution           149 



Application Examples 
 

Equipment Setup: Transmitter-Intra-Pair Skew 

To set up a Transmitter to measure Intra-Pair Skew, follow these steps: 

 

Figure 201: DVI monitor setup 

1. Connect the DVI monitor to the DVI port of the AGP ADD Card of the PC. 
Set the required screen resolution and the refresh rate. Set the host computer 
to run with a Half Clock Pattern to conduct the test. For information on how 
to set the host computer to run with a Half Clock Pattern to conduct the test, 
see page 191. 

2. Remove the DVI monitor and attach the TPA-P fixture to the DVI port of 
the DUT. 
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Figure 202: TPA-P fixture to the transmitter setup 

3. Use the application to define Tbit: 

� If you have not calculated the Tbit value  

� If you have changed the device, resolution, refresh or the blanking rate 
after calculating the Tbit  

4. Connect two single-ended probes to the Rx0+ of one data pair and Rx0− of 
the same data pair as shown in the Figure 203. 
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Figure 203: TPA-P test points 

5. In the application measurement configuration screen, set the Pair option 
from the drop-down menu and press Run. 

Transmitter Inter-Pair Skew 

Specifying the Equipment: Transmitter-Inter-Pair Skew 

You need the following equipment to set up the application and test Inter-Pair 
Skew in a Transmitter: 

� CSA7404, CSA7404B, TDS7404, TDS7404B, TDS7254, TDS7524B, 
TDS7704B, TDS6604, TDS6404, TDS6604B, TDS6804B, DPO7354, and  
DPO/DSA70000 series oscilloscope with recommended firmware version 

� P7240 or P6249 single-ended probe (two numbers) 

� SMA cable 

� TPA-P test fixture 

� Device Under Test 
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Equipment Setup: Transmitter-Inter-Pair Skew 

To set up a Transmitter to measure Inter-Pair Skew, follow these steps: 

:  

Figure 204: DVI monitor setup 

1. Connect the DVI monitor to the DVI port of the AGP ADD Card of the PC. 
Set the required screen resolution and the refresh rate. Set the host computer 
to run with a Half Clock Pattern to conduct the test. For information on how 
to set the host computer to run with a Half Clock Pattern to conduct the test, 
see page 191. 

2. Remove the DVI monitor and attach the TPA-P fixture to the DVI port of 
the DUT.  
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Figure 205: TPA-P fixture to the transmitter setup 

3. Use the application to define Tbit if: 

� If you have not calculated the Tbit value  

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  

4. Connect two single-ended probes to the Rx0+ of one data pair and Rx1− of 
the same data pair as shown in Figure 206. 

154                                       TDSDVI-DVI Compliance Test Solution 



Application Examples 
 

 

Figure 206: TPA-P test points 

5. In the application measurement configuration screen, set the Pair option 
from the drop-down menu and press Run. 

Cable Pk-Pk Jitter 

Specifying the Equipment: Cable-Pk-Pk Jitter 

You need the following equipment to set up the application and Pk-Pk Jitter in a 
Cable: 

� CSA7404, CSA7404B, TDS7404, TDS7404B, TDS7254, TDS7524B, 
TDS7704B, TDS6604, TDS6404, TDS6604B, TDS6804B, DPO7354, and  
DPO/DSA70000 series oscilloscope with recommended firmware version 

� P7350, P7330, P6330 (need TCA-BNC adapter) differential probe 

� SMA cable 

� TPA-R test fixture  

� Device Under Test 
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Equipment Setup: Cable Pk-Pk Jitter 

To set up a Cable to measure Jitter, follow these steps: 

1. Connect the TPA-R board to the end of the cable. 

 

 

Figure 207: Cable Jitter setup 

2. Use the application to define Tbit if: 

� If you have not calculated the Tbit value  

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  

3. Connect a P7350, P7330 or P6330 probe from any one of the four channels 
of the oscilloscope to the transmitted clock (Rxc+/−) on the TPA-R board.  

4. Connect the SMA cable from the remaining three channels on the 
oscilloscope to the SMA connector (PLL Clock) on the TPA-R board.  

5. Configure the measurement and run the application. 
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Cable Intra-Pair Skew 

Specifying the Equipment: Cable Intra-Pair Skew 

You need the following equipment to set up the application and test Intra-Pair 
skew in a Cable: 

� CSA7404, CSA7404B, TDS7404, TDS7404B, TDS7254, TDS7524B, 
TDS7704B, TDS6604, TDS6404, TDS6604B, TDS6804B, DPO7354, and  
DPO/DSA70000 series oscilloscope with recommended firmware version 

� P7240 or P6249 single-ended probes (two numbers) 

� SMA cable 

� TPA-R test fixture 

� ESB board 

� DVI-compliant cable 

� Device Under Test 

Equipment Setup: Cable Intra-Pair Skew 

To set up a Cable to measure Intra-Pair Skew follow these steps: 

1. Select and transmit the half clock pattern from the ESB board. 

2. Connect the TPA-R board to the end of the cable. 
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Figure 208: Cable Intra-Pair Skew setup 

3. Use the application to define Tbit if: 

� If you have not calculated the Tbit value  

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  

4. Connect two single-ended probes in TPA-R to the Rx0+ of one data pair and 
Rx0− of the same data pair. 
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Figure 209: TPA-R test points 

5. In the application measurement configuration screen, set the Pair option 
from the drop-down menu and press Run. 

Cable Inter-Pair Skew 
Specifying the Equipment: Cable Inter-Pair Skew 

You need the following equipment to set up the application and test Inter-Pair 
Skew in a Cable: 

� CSA7404, CSA7404B, TDS7404, TDS7404B, TDS7254, TDS7524B, 
TDS7704B, TDS6604, TDS6404, TDS6604B, TDS6804B, DPO7354, and  
DPO/DSA70000 series oscilloscope with recommended firmware version 

� P7240 or P6249 single-ended probe (two numbers) 

� SMA cable 

� TPA-R test fixture  

� ESB board 
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� DVI-compliant cable 

Equipment Setup: Cable Inter-Pair Skew 

To set up a Cable to measure Inter-Pair Skew follow these steps: 

1. Select and transmit the half clock pattern from the ESB board. 

2. Connect the TPA-R board end to the cable. 

 

 

Figure 210: Cable Inter-Pair Skew setup 

3. Use the application to define Tbit: 

� If you have not calculated the Tbit value  

� If you have changed the device, resolution, refresh rate, and blanking 
rate after calculating the Tbit  

4. Connect two single-ended probes in TPA-R to the Rx0+ of one data pair and 
Rx1− of the same data pair. For a photographic representation of the TPA-R 
test points, see page 196. 
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Figure 211: TPA-R test points 

5. In the application measurement configuration screen, set the Pair option 
from the drop-down menu and press Run. 

Cable Hi-Amplitude/Low-Amplitude Eye Diagram 
Specifying the Equipment: Cable High-Amplitude/Low-Amplitude Eye Diagram 

You need the following equipment to set up the application and test High-
Amplitude/Low-Amplitude Eye Diagram in a Cable: 

� CSA7404, CSA7404B, TDS7404, TDS7404B, TDS7254, TDS7524B, 
TDS7704B, TDS6604, TDS6404, TDS6604B, TDS6804B, DPO7354, and  
DPO/DSA70000 series oscilloscope with recommended firmware version 

� P7350, P7330 or a P6330 (need TCA-BNC adapter) differential probes  

� SMA cable 

� TPA-P test fixture 

� TPA-R test fixture 
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� ESB board 

� DVI-compliant cable 

� Device Under Test 

Equipment Setup: Cable-High-Amplitude/Low-Amplitude Eye Diagram 

The DVI Specifications version 1.0 specifies eye masks at TP2 (Low or High 
amplitude eye mask) and at TP3. The TP2 and TP3 test points are shown in the 
following figure. 

 

Figure 212: TP2 and TP3 test points 

� Select File> Preferences> Advanced tab from the application menu bar. 

Note: For expert users—If you have a standard signal that passes low or high 
amplitude mask, you may not opt to test cable at TP2 with low or high amplitude 
mask every time you run the cable measurement. For this purpose, we 
recommend that you select File> Preferences> Advanced> Cable Eye Diagram 
Test Point options. If you have selected File> Preferences> Advanced> Cable 
Eye Diagram Test Point> Test at TP2, follow step 1-7 in the procedure given 
below. If you have selected File> Preferences> Advanced> Cable Eye Diagram 
Test Point> Test at TP3, follow step 9- 12 in the procedure given below. 
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To set up a Cable to measure High-Amplitude/Low-Amplitude Eye Diagram, 
follow these steps: 

1. Connect the TPA-P fixture to the Equivalent Source Board (ESB).  

 

Figure 213: TPA-P to ESB setup 

2. Use the application to define Tbit: 

� If you have not calculated the Tbit value  

� If you have changed the device, resolution, refresh rate, or blanking 
rate after calculating the Tbit  

3. Select the Cable> High-Amplitude/Low-Amplitude Eye Diagram 
measurement. 

4. Connect a P7330, P7350 or P6330 probe from any one of the four channels 
of the oscilloscope to one of the data pairs (Rx0+/−, Rx1+/−, Rx2+/−) of the 
TPA-P fixture. Figure 214 shows the Rx0 test point. Similarly, perform the 
tests in Rx1 and Rx2 test points. 

5. Connect the SMA cable to either one of the remaining three channels on the 
oscilloscope to the (PLL CLk) on the TPA-P fixture in Figure 214. 

Note: You can refer to the TPA-P test points for Rx1 and Rx2 data pairs on  
page 194. 
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Figure 214: TPA-P test points 

6. Configure the application in the measurement configuration screen. 

7. Press Run to run the Cable Low/ High Amplitude test. The application 
performs the test and displays the results. If the signal fails, adjust the 
amplitude in the ESB board and start from step one. See page 193. 

8. If the signal passes the test, remove the TPA-P fixture. 

9. Connect one end of the cable (DUT) to the ESB and the other end to the 
TPA-R fixture.  
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Figure 215: TPA-R to ESB setup 

10. Connect a P7330, P7350 or P6330 probe from the selected data channel to 
one of the data pairs (Rx0+/−, Rx1+/−, Rx2+/−) of the TPA-R board. 
Figure 216 shows the Rx0 test point. Similarly, you can perform the tests in 
Rx1 and Rx2 test points shown in Figure 216. 

11. Connect the SMA cable from the selected trigger channel to the (PLL Clk) 
on the TPA-R board. 
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Figure 216: TPA-R test points 

If you have selected the TP3 test point in File> Preferences> Advanced tab, 
configure the application and select the run button. If you have selected Test at 
TP2 & TP3 option, continue measuring the cable High/ Low Amplitude Eye 
diagram. 
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Receiver Hi-Amplitude/Low-Amplitude Eye Diagram 

Specifying the Equipment: Receiver High-Amplitude/ Low-Amplitude Eye Diagram 

You need the following equipment to set up the application and test High-
Amplitude/Low-Amplitude Eye Diagram in a Receiver: 

� CSA7404, CSA7404B, TDS7404, TDS7404B, TDS7254, TDS7524B, 
TDS7704B, TDS6604, TDS6404, TDS6604B, TDS6804B, DPO7354, and  
DPO/DSA70000 series oscilloscope with recommended firmware version 

� P7350, P7330 or a P6330 (need TCA-BNC adapter) differential probe  

� SMA cable 

� TPA-R test fixture 

� ESB board 

� DVI-compliant cable 

� Device under test 

Equipment Setup Receiver: High-Amplitude/Low-Amplitude Eye Diagram 

To set up a Receiver to measure High-Amplitude/Low-Amplitude Eye Diagram, 
follow these steps: 

1. Connect the ESB, Cable and the TPA-R fixture. 

 

Figure 217: TPA-R to ESB setup 
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2. Use the application to define Tbit if: 

� You have not calculated the Tbit value  

� You have changed the device, resolution, refresh rate, or blanking rate 
after calculating the Tbit  

3. From the application menu, select Receiver> High-Amplitude/Low-
Amplitude Eye Diagram measurement. 

4. Connect a P7330, P7350 or P6330 probe from any one of the four channels 
of the oscilloscope to one of the data pairs (Rx0+/−, Rx1+/−, Rx2+/−) of the 
TPA-R board. Figure 218 shows the Rx0 test points. Similarly, perform the 
tests in Rx1 and Rx2 test points shown in Figure 218. 

5. Connect the SMA cable to either one of the remaining three channels of the 
oscilloscope and the PLL Clock of the TPA-R board. 

 

Figure 218: TPA-R test points 

6. Configure the application.  

7. Press Run to perform the measurement. 
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8. The application displays the message “Connect the PRP signal and press 
OK.” Select the PRP pattern on the ESB and press OK. 

9. The application performs the Low/High Amplitude eye mask test. If the 
signal passes the test, continue with the next step. If the signal has failed, 
increase or decrease the Vswing and run the test again until it passes. See 
page 193 for information on how to adjust Vswing. 

10. Remove the TPA-R and connect the display device (DUT) to the receiver as 
shown below. 

 

Figure 219: Receiver to the DUT setup  

11. If the monitor displays the correct pattern on the screen, the display device 
passed the test. 

Note: Unlike other measurements, the result status for the receiver measurement 
indicates that only the signal has passed and not the receiver device itself. 
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Measurement Algorithms 

Eye 
The application determines the mask geometry from Tbit and Vswing using a 
transmitted clock signal and a differential data signal, respectively. The 
application positions the mask at the center of the worst eye opening. The eye 
that has the least horizontal opening (worst eye opening) is calculated using the 
crossover detection algorithm. The six masks for the three types of devices are: 

� Transmitter Eye mask 

� Cable High Amplitude Eye mask 

� Cable Low Amplitude Eye mask 

� Cable TP3 Limit Eye mask 

� Receiver High Amplitude Eye mask 

� Receiver Low Amplitude Eye mask 
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Eye Openings 
Vertical opening (Vopen) 

 

Figure 220: Eye definitions 

The vertical eye opening is the minimum voltage difference between the high and 
low states after the transition. The application calculates the vertical opening at 
the worst eye opening and places the mask at the center of the worst eye opening. 
The center of the worst opening is calculated using the following equation: 

Center of worst opening eye = (T1+T2)/2.0 

Where:  

T1 is the time at the least opening eye’s left cross over 

T2 is the time at the least opening eye’s right cross over 

Application considers the 18% before and after the center of the unit interval 
region as the after and before transition period and calculates the minimum 
voltage difference in this region. This voltage is called vertical opening. 
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Horizontal Opening 

The minimum time difference between two crossovers of the eye diagram. This 
includes the effects of jitter.  

Overshoot 

Overshoot is voltage difference between the peak (+ve or −ve) and the 
normalized level (Vswing Low or Vswing High) in the previous eye diagram.  

The application calculates Overshoot using the following method: 

1. Find the minimum eye opening or the worst eye opening. 

2. Find the positive peak and negative peak in the eye. 

3. Find the normalized High (Vswing High) and Low (Vswing Low) using the 
histogram.  

4. You can calculate: 

� Overshoot1 = Positive peak - normalized high 

� Overshoot2 = Normalized low - Negative Peak 

5. The greater of Overshoot1 and Overshoot2 is used as Overshoot. 

Undershoot 

Undershoot is the voltage difference between the minimum high level voltage or 
the maximum low level voltage after the transition and the normalized voltage 
level (Vswing Low or Vswing High) in the eye diagram. 

The application calculates Undershoot using the following method: 

1. Find the minimum eye opening or the worst eye opening. 

2. Find the minimum level high voltage and maximum level low voltage in the 
after transition region in the eye diagram. 

3. Find the normalized High (Vswing High) and Low (Vswing Low) using the 
histogram.  

4. You can calculate: 

� Undershoot1 = the minimum level high voltage - normalized high 

� Undershoot2 = maximum level low voltage - Negative Peak 

5. The greater of Undershoot1 and Undershoot2 is used as Undershoot. 
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Inter-Pair Skew 
Definition: 

Inter-Pair Skew is the skew between the different data pairs that make up the 
TMDS signal. For example, the skew between Rx0+ of one pair and Rx1− is 
called Inter-Pair Skew. Use the single ended probe to run Inter-Pair Skew 
measurement. 

Algorithm: 

 

Figure 221: Calculation of Inter-Pair Skew 

The application calculates the 50% of Pk-Pk voltage level in both signals and 
calculates the time difference between the two edges of the waveform.  

The average of all the skew values over the acquisition period is compared with 
the Skew limits. The application calculates the Mean and Standard Deviation 
using the following equations: 

If t1, t2, .......tn are the skew values, 

 

 

 

Where: 

n= number of skews 

Intra-Pair Skew 
Definition: 
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Intra-Pair Skew is the skew between the same data pairs that make up the TMDS 
signal. For example, the skew between Rx0+ of one pair and Rx0− of the same 
data pair is called Intra-Pair Skew measurement. Use the single ended probe to 
run Intra-Pair Skew measurement. 

Algorithm: 

 

Figure 222: Calculation of Intra-Pair Skew 

The application calculates the 50% of Pk-Pk voltage level in both signals and 
calculates the time difference between the two edges of the waveform.  

The average of all the skew values over the acquisition period is compared with 
the Skew limits. The application calculates the Mean and Standard Deviation 
using the following equations: 

If t1, t2, .......tn are the skew values, 

 

 

Where: 

n= number of skews 

Assumption 

The application uses this algorithm with the assumption that both the data 
channels will transmit the same data content simultaneously. 
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Pk-Pk Jitter 
Cable Jitter is calculated as the peak-to-peak histogram value. To calculate Pk-Pk 
Jitter: 

1. Use the extracted clock to trigger the oscilloscope. 

2. Place the histogram at the 50% level of the transmitted clock's second rising 
edge. 

3. Measure the Pk-Pk histogram value as the Jitter value. 

Rise and Fall Time 
Rise Time: 

Rise Time is the time interval between the 20% and 80% of normalized 
amplitude of the TMDS signal at Rising edge. 

Fall Time: 

Fall time is the time interval between the 80% and 20% of normalized amplitude 
of the TMDS signal at falling edge. 

 

 

Figure 223: Calculation of Rise and Fall Time 

Low Ref = Normalized Voltage Low + 0.2 *Vswing 

High Ref = Normalized Voltage Low + 0.8 *Vswing 

Vswing = Normalized Voltage High - Normalized Voltage Low calculated using 
the Eye diagram. 
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Each edge is defined by the slope, voltage reference level (threshold), and 
Hysteresis.  

The application calculates this measurement using the following equation: 

Rime Time = T HighRef – T LowRef (at Rising Edge) 

Fall Time = T LowRef - ThighRef (at Falling Edge) 

Application calculates all rise and fall times in the acquisition and finds Min, 
Max, Mean, and SD.  

The mean value is compared with the limit value. 

Assumption 

For user Vswing value, the application needs a differential signal. The Absolute 
value of Vswing Low and Vswing high should be the same.  

Generation of Cable High Amplitude Eye Mask 

 

Figure 224: Cable High-Amplitude Eye mask 

The application calculates the eye mask coordinates as a percentage of Tbit value 
with fixed voltage level. 
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Generation of Cable Limit Eye Mask 

 

Figure 225: Cable Limit Eye mask 

The application calculates the eye mask coordinates as a percentage of Tbit value 
with fixed voltage level. 

Generation of Cable Low Amplitude Eye Mask 

 

Figure 226: Cable Low-Amplitude Eye mask 

The application calculates the eye mask coordinates as a percentage of Tbit value 
with fixed voltage level. 
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Generation of Receiver High Amplitude Eye Mask 

 

Figure 227: Receiver High-Amplitude Eye mask 

The application calculates the eye mask coordinates as a percentage of Tbit value 
with fixed voltage level. 

Generation of Receiver Low Amplitude Eye Mask 

 

Figure 228: Receiver Low-Amplitude Eye mask 

The application calculates the eye mask coordinates as a percentage of Tbit value 
with fixed voltage level. 

TDSDVI-DVI Compliance Test Solution           179 



Measurement Algorithms 
 

Generation of Transmitter Eye Mask 

 

Figure 229: Transmitter Eye mask 

The application calculates the eye mask coordinates as a normalized Tbit value 
with fixed voltage level. 
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Equivalent Source Board 
Use the ESB to test the cable assembly and receiver devices. The board has a: 

� Test pattern generator (HCP or PRP) 

� TMDS transmitter  

� DVI receptacle to connect the cable assembly or receiver under test. 

 

         Figure 230: ESB board 

ESB has a test pattern generator and a LCD module for a user interface to set the 
test modes (pattern choices and durations). To perform a test, select the 
appropriate resolution and pattern to be transmitted. ESB generates the required 
TMDS pattern along with the required DVI control signals for the Receiver test. 
You can also use the ESB to adjust the amplitude of a generated DVI signal. 

The ESB requires a clock source to generate a pattern and introduce jitter in the 
TMDS clock. We recommend that you use a Tektronix AWGxxx as a clock 
source. 

If you do not have the ESB setup, you can use the following setup to create a 
DVI signal: 
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Figure 231: ESB board setup with AWG and DG 

 

1. You can use the DG2020 to generate the required pattern with the DVI 
control signals. 

2. AWGxxx serves as a clock source for the pattern generator (DG2020A). 

3. By introducing jitter in the clock source, you can generate a jittery DVI 
signal for receiver testing. 

4. A custom made Transmitter chip/board: 

� Converts the parallel data from the pattern generator to a DVI signal. 

� Provides an option to adjust the amplitude of the TMDS signals. 
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Shortcut Keys  
 The following table lists the shortcut keys to access the application: 

Table 29: Menu options and their shortcut keys 
Menu Shortcut Keys 

File 
File Alt+ F 
Recall Default Alt F+D 
Save Alt F+V 
Recall Alt F+A 
Recently Saved Alt F+N 
Recently Recalled Alt F+Y 
Preferences AltF+E 
Minimize Alt F+Z 
Exit Alt F+X 
Measurements 
Measurements Alt+M 
Select Alt M+S 
Configure Alt M+C 

Results 
Results Alt+R 
Result Detail Alt R+l 
Utilities 
Utilities Alt+U 
Report Generator AltU+G 
Compare Results AltU+P 
Help 
Help Alt+ H 
Topics AltH+O 
About TDSDVI AltH+B 
Contact Tektronix AltH+T 
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Default Settings 
The following table lists the default parameter settings for the application: 

Table 30: Default parameter settings 
Parameter Selection Default Settings 
Device type tab Transmitter, Cable Receiver Tbit 
Define Tbit>Transmitter Clock CH1 through CH4 Ch1 
Define Tbit> User (T TDS66604, TDS6404, TDS6604B, TDS6804B, 
TDS7404, TDS7404B, TDS7704B, CSA7404, CSA7404B, 
DPO7354, and DPO/DSA70000 series oscilloscope) 

Min-200ps, Max-20ns 1.2ns 

Define Tbit> User (TDS7254/ TDS7524B) Min-1ns, Max-20ns 1.2ns 
Transmitter> Eye, Rise Time, Fall Time 
Transmitter> Eye Diagram> Configure> Select Source Data-CH1 through CH4 

Trigger-CH1 through CH4 
Ch1 
Ch2 

Transmitter> Eye Diagram> Configure> Select Pair Rx0, Rx1, Rx2 Rx0 
Transmitter> Eye Diagram> Configure> Eyes Min-2, Max-10 2 
Transmitter> Eye Diagram> Vswing> Pattern Pseudo Random, Half Clock  Pseudo Random 
Transmitter> Eye Diagram> Vswing> User Min-200mV, Max-2 Volts 400mV 
Transmitter, Cable> Pk-Pk Jitter 
Pk-Pk Jitter> Source> Transmitter Clock CH1 through CH4 Ch1 
Pk-Pk Jitter> Source> Trigger CH1 through CH4 Ch2 
Transmitter, Cable> Intra-Pair Skew, Inter-Pair Skew 
Intra-Pair Skew, Inter-Pair Skew> Source1 CH1 through CH4 Ch1 
Intra-Pair Skew, Inter-Pair Skew> Source2 CH1 through CH4 Ch2 
Intra-Pair Skew, Inter-Pair Skew> Pair Rx0, Rx1, Rx2 Rx0 
Inter-Pair Skew> Pair1 Rx0, Rx1, Rx2 Rx0 
Intra-Pair Skew, Inter-Pair Skew> Hysteresis Min-2%, Max-10% 5% 
Intra-Pair Skew> Pair2 Rx0, Rx1, Rx2 Rx1 
Transmitter> Rise Time, Fall Time 
Rise Time, Fall Time> Hysteresis Min-2%, Max-10% 5% 
Receiver, Cable> High-Amplitude Eye, Low-Amplitude Eye 
High-Amplitude Eye, Low-Amplitude Eye> Select Source> Data CH1 through CH4 Ch1 
High-Amplitude Eye, Low-Amplitude Eye> Select Source> Trigger CH1 through CH4 Ch2 
High-Amplitude Eye, Low-Amplitude Eye> Select Pair> Pair Rx0, Rx1, Rx2 Rx0 
High-Amplitude Eye, Low-Amplitude Eye> Eyes Min-2, Max-10 2 
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Table 30: Default parameter settings (Cont.) 
Parameter Selection Default Settings 

Utilities> Report Generator 
Report Setup> Clock Frequency> Resolution For TDS/CSA7404/7404B, TDS7704B, 

TDS6604, TDS6404, TDS6604B, TDS6804B, 
DPO7354, and DPO/DSA70000 series 
oscilloscope see page 190 and for 
TDS7254/TDS7524B oscilloscopes  
see page 190

VGA 

Report Setup> Clock Frequency> Refresh Rate 43, 56, 60, 70, 72, 75, 85 (These refresh rates 
vary and are available depending on the 
selected resolution)  

60Hz 

Preferences 
File> Preferences> User Preferences> Min number of 
Acquisitions 

Min-500k, Max-5M 
(For TDS/CSA7404/7404B, TDS7704B and 
TDS7254/TDS7254B oscilloscopes) 
Min-10K, Max-1M (For TDS6604, TDS6404, 
TDS6604B, and TDS6804B oscilloscopes) 

1M 
 
 
 
20k 

Error Codes 
The following table lists the error codes for the application: 

Table 31: Error codes, descriptions, and troubleshooting 
Error 
Code 

Display Information Detailed Description Probable Solution 

101 There are no results to generate a 
report 

If you try to generate a report without any results 
for the selected measurement, the application 
displays this error message. 

Press the Run button and perform the 
measurement again. 

111 Not enough acquisitions to perform 
measurement 

The application expects to acquire a minimum 
number of acquisitions specified by you. 

Make sure that the application 
configurations are proper. Check the 
probes and the test fixture connections. 

113 Error in importing waveform from 
the instrument 

The application could not import the waveform 
from the acquisition. This happens when there is 
no valid waveform in the acquisition memory. 

Make sure that the probes and test 
fixture are properly connected and re-
acquire the new waveform. 

114 Improper waveform Signal is not probed at the proper test points. Follow the setup diagram and probe the 
proper signal for the particular 
measurement. 
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Table 31: Error codes, descriptions, and troubleshooting (Cont.) 
Error 
Code 

Display Information Detailed Description Probable Solution 

115 Failed to find the required edges on 
the waveform 

Number of edges found on the source waveform 
is lesser than the minimum number of edges 
required to run the measurement. 

a) Decrease the horizontal scale to have 
more complete cycles of the waveform. 
b) Adjust the hysteresis level of the 
signal to find the edge at the required 
level. 

122 Same source cannot be selected 
for data and trigger source 

You cannot select the same source for Data and 
Trigger. 

Select different channel sources for 
Data and Trigger. 

123 Same source cannot be selected 
for both the data pairs 

You cannot select the same source for both the 
data pairs. 

Select Different data pair sources. 

124 Same source cannot be selected 
for Tx clock and trigger source 

You cannot select the same source for Tx Clock 
and trigger. 

Select different channel sources for Tx 
clock and trigger. 

125 Same source cannot be selected 
for source1 and source2 

You cannot select the same source for source1 
and source2. 

Select different channel sources for 
source1 and source2. 

131 Invalid file name The file name should not have any of the following 
characters: 
|,:,//,\\,,,<,>,*,\",/,?,@,^,~,$,#,%,&,(,),+,;,`,{,},[,],' 

Make sure to use valid characters in file 
names. 

132 Use valid .htm or .html extensions  The file extension for the report should be .htm or 
.html. 

Check if the extensions of the report 
file(s) are .htm or .html. 

133 Error while generating report The error is generated if there is no waveform plot 
in C:\TekApplications\TDSDVI\Reports 

Press the run button and perform the 
measurement again. 

134 A valid device Id cannot contain 
special characters. 
|,:,//,\\,,,<,>,*,\",/,?,@,^,~,$,#,%,&,(,)
,+,;,`,{,},[,],' 

The device Id should not have any special 
characters mentioned in the error display. 

Check whether the Device Id contains 
the special characters mentioned in the 
error display. 

135 A valid device prefix cannot contain 
special characters. 
|,:,//,\\,,,<,>,*,\",/,?,@,^,~,$,#,%,&,(,)
,+,;,`,{,},[,],' 

The device prefix should not have any special 
characters as mentioned in error display. 

Check whether the Device prefix 
contains the special characters as 
mentioned in the error display.  

141 Unable to calculate Vswing. 
Connect the proper signal or select 
the cursor option from File> 
Preferences to obtain the Vswing 
value 

If the signal(s) or the test fixture connections are 
not proper, the application is not able to calculate 
the Vswing.  

Connect the proper signal or select the 
cursor option from File> Preferences 
menu to obtain Vswing value. 

142 Unable to find the worst eye. 
Connect the proper signal or select 
the cursor option from File> 
Preferences to obtain worst eye 
opening 

If the signal (s) or the test fixture connections are 
not proper, the application is unable to find the 
worst eye opening. 

Connect the proper signal or select the 
cursor option from File> Preferences to 
obtain the Worst Eye value. 

143 Improper Vswing or invalid signal The application is unable to calculate the Vswing 
or when you enter an invalid Vswing. This 
happens if the signal(s) or the test fixture 
connections are not proper or cursor is not placed 
at the proper position. 

Connect the proper signal or place the 
cursor at the proper position to obtain 
the Vswing value or enter a valid 
Vswing. 
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Table 31: Error codes, descriptions, and troubleshooting (Cont.) 
Error 
Code 

Display Information Detailed Description Probable Solution 

144 The worst Tbit is greater than the 
calculated Tbit value 

If the cursor is placed at the wrong position in the 
eye to find the Worst Eye or if the user Tbit value 
is invalid, this message appears. 

Select File> Preferences> Use cursors 
for Eye, RT & FT testing box. Place the 
cursor in the worst Tbit crossover points 
to find the worst Tbit or  
Use the calculate option in Define Tbit 
pane to calculate the Tbit value. 

145 The Vswing value does not meet 
the specification 

The Vswing value should be with in the specified 
range of 800mV –1.2V. 

Connect the proper signal or place the 
cursor at the proper position to obtain 
the Vswing value. 

151 Error while deleting waveform from 
Ref1 

The application failed to delete the Reference 
waveform.  

Press the Run button and perform the 
measurement again.  

161 Error in result comparison The error is generated if there is no waveform plot 
in C:\TekApplications\TDSDVI\Reports 
(for Current Vs File option) or waveform plot not 
found for the selected files. 

Press the run button and perform the 
measurement again to get the waveform 
plot. 

162 Not a compatible result comparison The error is generated if compared files are not 
compatible. 

Select compatible files. 

163 Not a valid path The error is generated if the path/report given for 
report comparison is not valid. The path should 
not have any of the following characters: 
|,:,//,\\,,,<,>,*,\”,/,?,@,^,~,$,#,%,&,(,),+,;,`,{,},[,],’ 

Select proper report and file path for 
comparison or check whether the path 
contains any special characters like 
|,:,//,\\,,,<,>,*,\”,/,?,@,^,~,$,#,%,&,(,),+,;,`,
{,},[,],’ 

164 Same path cannot be selected for 
input and output files 

The result comparison input file and destination 
path cannot be the same. 

Select different path for input and output 
file to compare results. 

165 Same path cannot be selected for 
both the input files 

The result comparison file vs file and the two input 
files cannot be the same. 

Select different path for the two input 
files to compare results. 

171 Please select a measurement to 
configure it 

Tbit does not have a separate configuration panel. 
You have to select a measurement and configure. 

The configure button can be used to 
configure measurements only. 

172 Invalid Tbit value If the Tbit value is not within the specified range of 
200ps and 20ns in the TDS6604, TDS6404, 
TDS6604B, TDS6804B, TDS7404, TDS7404B, 
TDS7704B, DPO7354, and DPO/DSA70000 
series oscilloscope and CSA7404, 
CSA7404B and between 1ns and 20ns in 
TDS7254 and TDS7254B oscilloscopes, the 
application displays this error message. 

Make sure you have selected the proper 
Tx Clock channel for Tbit measurement 
or 
Check the test fixture connections or 
Change the resolution and/or the refresh 
rate and re-calculate Tbit. 

173 Tbit calculation failed The Tbit measurement has failed. If the Tx clock 
selected is not proper, the Tbit calculation can fail.

Make sure that the application has 
selected proper Tx Clock channel for 
Tbit measurement or check the test 
fixture connections. 
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Table 31: Error codes, descriptions, and troubleshooting (Cont.) 
Error 
Code 

Display Information Detailed Description Probable Solution 

174 The device is not ready If the destination location for saving zoomed eye 
is not valid, the application displays this error 
message. 

Check if the specified drive and folder to 
save zoomed eye is valid and ready. 

175 Tbit value is not defined If you try running a measurement without defining 
the Tbit value, the application displays this error 
message. 

Use the Calculated or the User option to 
define Tbit before running a 
measurement. 

176 Test is not completed If you have selected TP2 &TP3 as test point for 
Cable High/Low amplitude testing, and the test is 
completed only for the TP2 test point, the 
application displays this error message. 

Analyze the possible reasons for the 
incomplete test at TP2 and run the test 
again. 

181 Mask coordinates are out of view The application is not able to calculate the mask 
coordinates. If the signal(s) or the test fixture 
connections are not proper or the cursor is not 
placed at proper position, this message appears. 

Increase the number of eyes in the 
configuration panel and run the test 
again. 

182 Error while saving the zoomed eye If the destination drive does not have enough 
memory to save the zoomed eye, the application 
displays this error message. 

Check if the destination drive is has 
enough memory to save the zoomed 
eye.  

183 File name should not exceed 50 
characters 

The setup file name entered to save or recall 
should not be more than 50 characters. 

Reduce the length of the file name. 

184 Invalid extension. 
File name should have .ini 
extension 

The setup file name entered to save to recall 
should have a valid ".ini" extension. 

Check if the file name has a valid ".ini" 
extension. 

185 The setup cannot be recalled. 
The file may be corrupted 

The recall operation is not successful because the 
recalled setup file may be corrupt. 

Replace the existing file if corrupt. 

186 The setup cannot be recalled. 
The .ini file does not exist 

The recall operation is not successful because the 
recalled setup file does not exist. 

Check if the .ini file exists. 
 

187 The setup is not saved successfully The setup file cannot be saved because there is 
not enough space on the disk. 

Check if there is enough space on the 
disk to save the setup file. 
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Standard Resolutions 
The following table lists the standard DVI resolutions: 

Table 32: Standard resolutions 
Resolution Refresh Rate Clock/Pixel Frequency 
640 x 350   
640 x 400   
720 x 400  

85 Hz 
85 Hz 
85 Hz 

31.500MHz 
31.500 MHz 
35.500 MHz 

640 x 480 (VGA) 60 Hz 
72 Hz 
75 Hz 
85 Hz 

25.175 MHz 
31.500 MHz 
31.500 MHz 
36.000 MHz 

800 x 600 
(SVGA) 

56 Hz 
60 Hz 
72 Hz 
75 Hz 
85 Hz 

36.000 MHz 
40.000 MHz 
50.000 MHz 
49.500 MHz 
56.250 MHz 

1024 x 768 
(XGA) 

43 Hz  
60 Hz 
70 Hz 
75 Hz 
85 Hz 

44.900 MHz 
65.000 MHz 
75.000 MHz 
78.750 MHz 
94.500 MHz 

1152 x 864 75 Hz 108.000 MHz 
1280 x 960 60 Hz 

85 Hz 
108.000 MHz 
148.500 MHz 

1280 x 1024 (SXGA) 60 Hz 
75 Hz 
85 Hz 

108.000 MHz 
135.000 MHz 
157.500 MHz 

1600 x 1200 (UXGA) 60 Hz 
65 Hz 
70 Hz 
75 Hz 
85 Hz 

162.000 MHz 
175.500 MHz 
189.000 MHz 
202.500 MHz 
229.500 MHz 

1792 x 1344 60 Hz 
75 Hz 

204.750 MHz 
261.000 MHz 

1856 x 1392 60 Hz 
75 Hz 

218.250 MHz 
288.000 MHz 

1920 x 1440 60 Hz 
75 Hz 

234.000 MHz 
297.000 MHz 

2048x1536(QXGA) 60 Hz 198.7 MHz 
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Resolutions on Supported Oscilloscopes 

TDS/CSA7404/7404B, TDS7704B and TDS6604, TDS6404, TDS6604B, TDS6804B, 
DPO7354, and DPO/DSA70000 series oscilloscope 

The following table lists the DVI resolutions on TDS/CSA7404/7404B, 
TDS7704B, TDS6604, TDS6404, TDS6604B, TDS6804B, DPO7354, and 
DPO/DSA70000 series oscilloscope: 

Table 33: Resolutions  
Resolutions 
640x350 
640x400 
720x400 
640x480(VGA) 
800x600(SVGA) 
1024x768(XGA) 
1152x864 
1280x960 
1280x1024(SXGA) 
1600x1200(UXGA) 
1792x1344 
1856x1392 
2048x1536(QXGA) 

TDS7254/TDS7254B Oscilloscopes 

The following table lists the DVI resolutions on TDS7254 and TDS7254B 
oscilloscopes: 

Table 34: Resolutions  
Resolutions 
640x350 
640x400 
720x400 
1600x1200(UXGA) 
640x480(VGA) 
800x600(SVGA) 
1024x768(XGA) 
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Generate Patterns (in infinite loops) to Conduct a Test 
With the host computer: 

1. Copy the patterns from the oscilloscope directory   
C:\TekApplications\TDSDVI\Patterns to the host computer. 

2. Open the specific resolution pattern with any image editor and maximize the 
pattern to full screen. For example, to transmit the XGA resolution PRP 
pattern infinitely, open the XGA resolution PRP pattern bit map in 
Microsoft Paint application. Select View> View Bitmap to maximize the 
pattern.  

3. The device will transmit the selected pattern continually until you exit the 
image editor. 

With the ESB board: 

Please refer the ESB specifications and user guide to generate infinite loop 
patterns. 

Set Cursors for Eye and Rise and Fall Time Testing 
The application automatically enables the oscilloscope's cursors relevant to each 
measurement. By default, the cursor option is not selected.  

Note: The Rise and Fall Time measurement uses cursors to calculate Vswing. In 
the Eye Diagram measurement, you can use cursors to calculate Vswing and 
select the worst eye opening. 
 

If you select File> Preferences> Use cursors for Eye, RT & FT testing: 

� To calculate Vswing, the application enables the horizontal cursors in the 
oscilloscope and displays the following message box. Place the cursors on 
the Vswing high and Vswing low of the eye diagram for the Rise and Fall 
Time and Eye Diagram measurement. Select OK to calculate Vswing. 

 

Figure 232: Cursors for Vswing message box 
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� To select the worst eye opening, the application enables the vertical cursors. 
Place the cursors at the crossover points of the worst eye opening for the 
Eye Diagram measurement. Select OK to set the worst eye. The application 
places the mask on the worst eye opening. 

 

Figure 233: Cursors at worst eye message box 

Cable Setup at TP2 
 

 

Figure 234: Cable setup at TP2 
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Increase or Decrease the Vswing 
If signal violates the mask at TP2, the test fails and you cannot proceed further 
for TP3 testing, use the following guidelines given below to pass the signal: 

� If the ESB generated TMDS signal violates the upper and/or the lower mask 
segments, decrease the Vswing value in the ESB. Refer the ESB 
specifications and user guide for information on how to adjust the Vswing. 

� If the ESB generated TMDS signal violates the middle mask, increase the 
Vswing value in the ESB. 

� If the ESB generated TMDS signal violates the horizontal opening in the 
eye mask, adjust the clock jitter. 

Cable Setup at TP3 
 

 

Figure 235: Cable setup at TP3 
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TPA-P Test Points 

 

Figure 236: TPA-P fixture 

 

 

 

Figure 237: TPA-P test points 

194                                       TDSDVI-DVI Compliance Test Solution 



Reference 
 

Figure 238 shows the component side view of the TPA-P fixture and the 
numbered list describes the corresponding components and the test points. 

� DVI Input connector 

� Power connector 

� JP1 1-2 for 5V, 2-3 for 3.3 V 

� PLL Clock output connector 

� P1, adjustable output swing 

� TMDS differential pair test points 

� JP2, shorted if using DVI 5V 

 

 

Figure 238: TPA-P fixture-component view 
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TPA-R Test Points 

 

Figure 239: TPA-R test points 
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About the Remote GPIB program 
The Remote GPIB feature provides a framework to remotely automate the 
TDSDVI application to perform DVI compliance testing. The Remote GPIB 
support can be used to select, configure and run all TDSDVI tests and supports 
the test report generation. An example of a Remote GPIB program that can 
execute the TDSDVI measurement is included with the application. The 
oscilloscope hard disk and optional applications disc both contain the file, 
TDSDVI_rgpib.c. On the hard drive, the file resides in the C:\Program 
Files\TekApplications\TDSDVI directory. 

This example shows how a Remote GPIB program executes the application to do 
the following tasks: 

1. Start up the application 

2. Select a measurement and configure the parameters 

3. Run the measurement 

4. Generate a report 

5. Exit the application 

Remote GPIB Reference Materials 
To use the Remote GPIB commands with your oscilloscope, refer to the 
following materials: 

� The TDSDVI_rgpib.c file on the oscilloscope hard drive (located in the 
C:\Program Files\TekApplications\TDSDVI directory) and optional 
application disc for an example of a Remote GPIB command that can 
execute the application. 

� The Remote GPIB Program Example section for guidelines to use while 
designing the Remote GPIB program. 

� The programmer information is in the online help of your oscilloscope. 

� The Guidelines to Remote GPIB Programming section in the Online Help. 
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Introduction to Remote GPIB commands 
With the knowledge of Remote GPIB command syntax, you can design a Remote 
GPIB program to do the following tasks: 

� Start the TDSDVI application 

� Recognize an active application with Remote GPIB protocol 

� Program and read the application setup parameters 

� Sequence measurements 

� Generate Report 

 

Guidelines to Remote GPIB Programming 
The TDSDVI application includes an example of a Remote GPIB program for 
your reference as a program example. Your Remote GPIB program should 
comply with the following guidelines: 

� Launch the application before sending any remote GPIB commands to the 
application (See the program example). 

� Before running the GPIB commands, you can use the *IDN? variable to 
identify the oscilloscope and ensure that the oscilloscope is responding. 

� GPIB commands do not work through LAN. 

� When the application processes remote GPIB commands, no messages are 
displayed. 

� For save, recall, and report generation, the successive file names should be 
different. 

� The application does not respond to commands that were sent before the 
application was activated. 

� To generate reports, first check whether the sequencer state is "Ready". 

� The status variable should be checked to ensure that an error has not 
occurred because of a measurement command problem. 

� Remote GPIB event queue needs to be monitored. You can use the call 
monitor to monitor the RGPIB event queue. Make sure the event queue is 
clear before sending the next Remote GPIB command to prevent event 
queue overflow. 

� Commands are case and space sensitive. Your program will not operate 
correctly if you do not follow the capitalization and spacing precisely. 
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� For information on error queries in Remote GPIB, refer to the Error Codes 
section in the Online Help.  

� Ensure that the return value of the "commandStatus" is true before sending 
the next command and that there is a delay of 1.0 sec between the 
commands. 

Note: Use TDSDVI in either the manual or Remote GPIB mode but not both the 
modes. 
 

Launching the Application using Remote GPIB 
 

You must manually set up the oscilloscope to launch the application.  

The application uses the Remote GPIB VARIABLE: VALUE command with 
arguments to execute some features. The set of Remote GPIB commands 
includes the variable names and variable values necessary to select, configure, 
and run the measurements and to generate reports in the Remote GPIB program. 

You can select and configure the measurements that you want to use with your 
Remote GPIB program. 

Note:When the application is launched, the default directory for the report files 
is set to C:\TekApplications\TDSDVI\Reports. 
 

 Note:In Remote GPIB mode, the setup files are saved and recalled only from the 
directory C:\TekApplications\TDSDVI\Setup. The save and recall name should 
be appended with .ini extension. 
 

GPIB Syntax 
VARIABLE:VALUE COMMAND accepts string arguments for a control or data 
variable and a value to which to set the argument. 

 Syntax  

VARIABLE:VALUE “<variable name>”,“<variable value>”  

The arguments <variable name> and <variable value> are required in the order 
indicated. 

VARIABLE: VALUE? “<Variable name>” for query 
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 Note:Commands are case and space sensitive. Your program will not operate 
correctly if you do not follow the capitalization and spacing precisely. 
 

 

 

TDSDVI Application Command Arguments and Queries 

Application Commands 
To start the application, send the Remote GPIB command application:activate 
"DVI Compliance Test Solution" to the oscilloscope. 

Table 35: Application 
Variable 
Name 

Valid Values Set Form Query Form 

application 
 

exit 
 

Setting the value will terminate a running 
application. 

Returns the name of the currently 
running application. 
 

Sequencing Commands 

Table 36: Sequencer 
Variable 
Name 

Valid Values Set Form Query Form 

sequencer
State 
 
 

Sequencing 
  
{Ready, Sequencing} 
 

This command is equivalent to running the 
measurement. 
Queries the state of the measurement - running or 
stopped. 
 

Returns the sequencer state. 
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Save/Recall Commands 

Table 37: Save/Recall 
Variable Name Valid Values Set Form Query Form 

setup 
 
 

{Default, Recall, Save} 
 

Sets the Save/Recall/Default 
action. 
 

The default value for this variable is 
an empty string.  
This variable is set to the selected 
value momentarily and returns to its 
default value after the task is 
complete. 
 

recallName 
 

Any string 1-50 characters from A-Z, 
0-9 
 

Sets the setup recall file name. 
The default path is 
C:\TekApplications\TDSDVI\Setup. 
You need to type in the .ini 
extension after entering the file 
name. 
 

Returns the setup recall file name. 
 

saveName 
 

Any string 1-50 characters from A-Z, 
0-9 
 

Sets the setup save file name.  
The default path is 
C:\TekApplications\TDSDVI\Setup.
You need to type in the .ini 
extension after entering the file 
name. 
 

Returns the setup save file name. 
 

 

Measurement Commands 

Table 38: Measurement  
Variable Name Valid Values Set Form Query Form 

measChanged 
 
 

{transmitterEyeDiagram, 
transmitterRiseandFallTime, 
transmitterPkPkJitter, 
transmitterInterPairSkew, 
transmitterIntraPairSkew, 
cableHighAmplitudeEyeDiagram, 
cableLowAmplitudeEyeDiagram, 
cablePkPkJitter, 
cableInterPairSkew, 
cableIntraPairSkew,  
receiverHighAmplitudeEyeDiagram, 
receiverLowAmplitudeEyeDiagram, 
tbitMeasurement} 
 

Sets the DVI Analysis 
measurement name. 
 

Returns the set DVI Analysis 
measurement name. 
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Transmitter Eye-Diagram Configuration Commands 

Table 39: Transmitter Eye-Diagram configuration 
Variable Name Valid Values Set Form Query Form 

dataChannelChange 
 
 
 

{Ch1, Ch2, Ch3, Ch4} 
 
 

Sets the source data channel. 
 
 

Returns the set source data channel. 
 

triggerChannelChange 
 

{Ch1, Ch2, Ch3, Ch4} 
 

Sets the source trigger channel.
 
 

Returns the set source trigger channel. 
 

dataPairChange 
 

{RX0, RX1, RX2} 
 

Sets the transmitter pair value. 
 

Returns the set transmitter pair value. 
 

numberOfEye 
 

Any integer value between 2 to 10. 
Use the following example while 
entering the values.  
Example: 2, 4, 7, 10. 
 

Sets the number of eyes 
required. 
 

Returns the number of eyes. 
 

vswingModeChange 
 

{pattern, user} 
 

Sets the Vswing mode required.
 

Returns the Vswing mode selected. 
 

vswingPatternChange 
 

{pseudoRandomPattern, 
halfClockPattern} 
 

Sets the Vswing pattern 
required to calculate Vswing. 
 

Returns the Vswing pattern selected. 
 

vswingUserValue 
 

Any double value between  
200 mV to 2.0 V. 
Use the following example while 
entering the values.  
Example: 200e-3, 450e-3, 1.2. 
 

Sets the user defined voltage 
value to calculate Vswing. 
 

Returns the set user defined voltage 
value to calculate Vswing. 
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Transmitter Rise-Time and Fall-Time Configurations Commands 

Table 40: Transmitter Rise Time and Fall Time configuration 
Variable Name Valid Values Set Form Query Form 

dataChannelChange 
 
 
 

{Ch1, Ch2, Ch3, Ch4} 
 
 

Sets the source data channel. 
 
 

Returns the set source data channel. 
 

triggerChannelChange 
 

{Ch1, Ch2, Ch3, Ch4} 
 

Sets the source trigger channel.
 
 

Returns the set source trigger channel. 
 

dataPairChange 
 

{RX0, RX1, RX2} 
 

Sets the transmitter data pair 
value. 
 

Returns the set transmitter pair value. 
 

hysteresisChange 
 

Any double value between 2 to 10 
percent. 
Use the following example while 
entering the values.  
Example: 2.0, 4.5, 10.0. 
 

Sets the rise time and fall time 
hysteresis value. 
 

Returns the set rise time and fall time 
hysteresis value. 
 

vswingModeChange 
 

{pattern, user} 
 

Sets the Vswing mode required.
 

Returns the Vswing mode selected. 
 

vswingPatternChange 
 

{pseudoRandomPattern, 
halfClockPattern} 
 

Sets the Vswing pattern 
required to calculate Vswing. 
 

Returns the Vswing pattern selected. 
 

vswingUserValue 
 

Any double value between  
200 mV to 2.0 V. 
Use the following example while 
entering the values.  
Example: 200e-3, 450e-3, 1.2. 
 

Sets the user defined voltage 
value to calculate Vswing. 
 

Returns the set user defined voltage 
value to calculate Vswing. 
 

 

Peak to Peak Jitter Configuration Commands 

Table 41: Peak to Peak Jitter  configuration (Transmitter and Cable) 
Variable Name Valid Values Set Form Query Form 

clockChannelChange 
 

{Ch1, Ch2, Ch3, Ch4} 
 

Sets the source clock channel. 
 

Returns the set source clock channel. 
 

triggerChannelChange 
 

{Ch1, Ch2, Ch3, Ch4} 
 

Sets the source trigger channel. 
 

Returns the set source trigger channel. 
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Intra-Pair Skew Configuration (Transmitter and Cable) Commands 

Table 42: Intra-Pair Skew configuration (Transmitter and Cable) 
Variable Name Valid Values Set Form Query Form 

source1Change 
 

{Ch1, Ch2, Ch3, Ch4} 
 

Sets the skew Source1 channel. 
 

Returns the set skew Source1 channel. 
 

source2Change 
 

{Ch1, Ch2, Ch3, Ch4} 
 

Sets the skew Source2 channel. 
 

Returns the set skew Source2 channel. 
 

skewHysteresisChange 
 

Any double value 
between 2 to 10 percent. 
Use the following 
example while entering 
the values.  
Example: 2.0, 4.5, 10.0. 
 

Sets the skew hysteresis value. 
 

Returns the set skew hysteresis value. 
 

dataPairChange 
 

{RX0, RX1, RX2} 
 

Sets the data pair value. 
 

Returns the set data pair value. 
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Inter-Pair Skew Configuration (Transmitter and Cable) Commands 

Table 43: Inter-Pair Skew configuration (Transmitter and Cable) 
Variable Name Valid Values Set Form Query Form 

source1Change 
 

{Ch1, Ch2, Ch3, Ch4} 
 

Sets the skew Source1 channel. 
 

Returns the set skew Source1 channel. 
 

source2Change 
 

{Ch1, Ch2, Ch3, Ch4} 
 

Sets the skew Source2 channel. 
 

Returns the set skew Source2 channel. 
 

skewHysteresisChange 
 

Any double value 
between 2 to 10 
percent. 
Use the following 
example while 
entering the values.  
Example: 2.0, 4.5, 
10.0. 
 

Sets the skew hysteresis value. 
 

Returns the set skew hysteresis value. 
 

dataPairChange 
dataPair2Change 

 

{RX0, RX1, RX2} 
{RX0, RX1, RX2} 

 

Sets the data pair value. 
Sets the data Pair2 value. 

 

Returns the set data pair value. 
Returns the set data Pair2 value. 

 
dataPair1PositiveChange 
 

true 
  
false  
 

Selects the data Pair1+ box. 
Deselects the data Pair1+ box. 
 

Returns true if data Pair1+ mode is 
selected or false if not selected. 

 

dataPair2PositiveChange 
 

true 
  
false  
 

Selects the data Pair2+ box. 
Deselects the data Pair2+ box. 
 

Returns true if data Pair2+ mode is 
selected or false if not selected. 

 

selectDifferentialProbe 
 

true 
  
false  
 

Selects the Differential Probe box. 
Deselects the Differential Probe box. 
 

Returns true if Differential Probe mode 
is selected or false if not selected. 
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High-Amplitude Eye Diagram (Cable and Receiver) Commands 

Table 44: High-Amplitude Eye Diagram (Cable and Receiver) 
Variable Name Valid Values Set Form Query Form 

dataChannelChange 
 
 

{Ch1, Ch2, Ch3, Ch4} 
 

Sets the source data channel. 
 

Returns the set source data channel. 
 

triggerChannelChange 
 

{Ch1, Ch2, Ch3, Ch4} 
 

Sets the source trigger channel. 
 

Returns the set source trigger channel. 
 

dataPairChange 
 
 

{RX0, RX1, RX2} 
 
 

Sets the cable data pair value. 
 

Returns the set cable data pair value. 
 

numberOfEye 
 

Any integer value 
between 2 to 10 
 

Sets the number of eyes required. 
 

Returns the number of eyes.  
 

 

Low-Amplitude Eye Diagram (Cable and Receiver) Commands 

Table 45: Low-Amplitude Eye Diagram (Cable and Receiver) 
Variable Name Valid Values Set Form Query Form 

dataChannelChange 
 
 

{Ch1, Ch2, Ch3, Ch4} 
 

Sets the source data channel. 
 

Returns the set source data channel. 
 

triggerChannelChange 
 

{Ch1, Ch2, Ch3, Ch4} 
 

Sets the source trigger channel. 
 

Returns the set source trigger channel. 
 

dataPairChange 
 
 

{RX0, RX1, RX2} 
 
 

Sets the cable data pair value. 
 

Returns the set cable data pair value. 
 

numberOfEye 
 

Any integer value 
between 2 to 10 
 

Sets the number of eyes required. 
 

Returns the number of eyes.  
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Defining T-Bit Configurations Commands 
 

Table 46: Defining T-Bit configuration 
Variable Name Valid Values Set Form Query Form 

tbitModeChange 
 
 

{user, calculated} 
 

Selects the Tbit mode required to define Tbit.
 

Returns the set Tbit mode required to 
define Tbit. 
 
 

tbitClkValueChange 
 

Any double value 
between  
200 ps to 20 ns. 
Use the following 
example while 
entering the values.  
Example: 300.0e-12, 
20.0e-9. 
 

Sets the user defined/calculated Tbit value. 
 

Returns the set user defined/calculated 
Tbit value. 
 

diffClockChannelChange 
 
 

{Ch1, Ch2, Ch3, Ch4} 
 
 

Sets the differential clock channel used to 
define Tbit. 
 

Returns the set differential clock 
channel to define Tbit. 
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General Preferences Selection Commands 

Table 47: General Preferences Selection 
Variable Name Valid Values Set Form Query Form 

reportShowState 
 

true 
  
false 
 

Opens the report file after generation. 
Does not open the report file after 
generation. 
 

Returns true if the Show report after 
generation box is selected or false if not 
selected. 
 

zoomedEyeInReport true 
  
false 

Uses the zoomed eye mask in the report 
generated. 
Does not use the zoomed eye mask in the 
report generated. 
 

Returns true if the Use zoomed eye 
mask in report box is selected or false if 
not selected. 
 

minAcquisition 
 

Any double value 
between 500k to 5M 
samples. 
Use the following 
example while 
entering the values.  
Example: 500e3, 
5.0e6. 
 

Sets the number of acquisitions required. 
 

Returns the number of acquisitions set. 

 

 

Advanced Preferences Selection Commands 

Table 48: Advanced Preferences Selection 
Variable Name Valid Values Set Form Query Form 

testPointChange {Ch1, Ch2, Ch3, Ch4} Selects the different test points. Returns the selected test point. 
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Report Setup Commands 

Table 49: Report Setup 
Variable Name Valid Values Set Form Query Form 

deviceId 
 

Any string 1-60 
characters from A-Z, 
0-9 without the use of 
special characters 
except the underscore

Sets the device ID of the device for report 
generation. 

Returns the set device ID. 
 

deviceDescription 
 

Any string from A-Z,  
0-9 without the use of 
special characters 
except the underscore

Sets the device description for the device 
during report generation. 
 

Returns the set device description. 
 

devicePrefix 
 

Any string 1-60 
characters from A-Z, 
0-9 without the use of 
special characters 
except the underscore

Sets the device prefix for automatic device 
IDs and report names. 

Returns the set device prefix. 

deviceAutomaticIdandReport 
 

true 
  
false 
 

Automatically generates the device IDs and 
report names. 
Does not generate the device IDs and 
report names automatically. 

Returns true if the Automatic ID's and 
Report Names box is selected or false if 
not selected. 

reportGenerationMode 
 

{manual, automatic} 
 

Selects the automatic or manual report 
generation mode. 

Returns the mode set for report 
generation. 

selectForReport 
 

true 
  
false 

Shows the selected resolution and refresh 
rate in the report to be generated. 
Does not show the selected resolution and 
refresh rate in the report to be generated. 

Returns true if the Select for Report box 
is selected or false if not selected. 
 

resolutionChange 
 

{VGA, SVGA, XGA, 
SXGA, UXGA, HDTV, 
QXGA, 640*350, 
640*400, 720*400, 
1152*864, 1280*960, 
1792*1344, 
1856*1392, 920*1440}

Sets the resolution in the report to be 
generated. 
 

Returns the set resolution. 
 

refreshRateChange 
 

{43, 56, 60, 65, 70,72, 
75, 85} 

Sets the refresh rate for a particular 
resolution in the report to be generated. 

Returns the set refresh rate. 
 

reportDirNameChange 
 

Absolute path name of 
the existing directory 

Changes the path name of the existing 
directory. 

Returns path name of the existing 
directory. 

reportFileNameChange 
 

Any string 1-60 
characters from A-Z, 
0-9 

Changes the file name of the report. 
Supports only HTM and HTML format types 
for the report file name. 

Returns the file name selected for the 
reports. 
 

reportGenerate 
 

generate 
 

Generates the report only if report 
generation mode is set to manual.  
 

The default value for this variable is an 
empty string.  
This variable is set to the selected value 
momentarily and returns to its default 
value after the task is complete. 
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Status/Error Commands 

Table 50: Error 
Variable Name Valid Values Set Form Query Form 

commandStatus 
 

true 

  

false 
 

Not applicable 

 
Returns true if the command has 
completed execution. 
Returns false if the command is 
under execution or not executed. 
For more information, refer the 
note on commandStatus. 

Status 
 

Valid error code or 
error string 

Not applicable Returns an error code or error 
string 

  

 Note: After every set command, you have to wait until the "commandStatus" 
variable returns a true value. Keep polling for <variable:value? 
“commandStatus”> and then issue the next set or get command. 
For the script to function correctly, ensure that the script follows this order: 
 
The  script recalls the default setup. 
variable:value “setup”,“Default” 
 
variable:value? “commandStatus”  
“false”    
 
…..keep polling until the return is true  
“true” 
 
When true, send the next command. 
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Program Example 
/* TDSDVI 

  
* This is a reference program to illustrate how to communicate to TDSDVI 

* using Remote GPIB commands. 

  

A typical application does following steps 

1.  Start up the application 

2.  Select a measurement and configure the parameters 

3.  Run the measurement 

4.  Generate a report 

5.  Exit the application 

  
For the current program, we will recall a setup file named as sqcsetup. 

  
You can save setup files according to your own needs using the GUI based 
interface of the application. 

  
*/ 

#include "stdafx.h" 

#include <windows.h> 

#include <stdio.h> 

#include <stdlib.h> 

#include "decl-32.h" 

/* Forward Declarations */ 

int start_application(int scope); 

int exit_application(int scope); 

int do_single_test (int scope); 

int recall_setup( int scope, char *filename); 
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/* parameters needed to access the device driver 
handler */ 

#define BDINDEX 0    // Board Index 

#define PRIMARY_ADDR_OF_DMM 1 // Primary address of 
device 

#define NO_SECONDARY_ADDR 0  // Secondary address of 
device 

#define TIMEOUT T10s   // Timeout value = 10 seconds 

#define EOTMODE 1    // Enable the END message 

#define EOSMODE 0    // Disable the EOS mode 

char    ErrorMnemonic[21][5] = {"EDVR", "ECIC", 
"ENOL", "EADR", "EARG", "ESAC", "EABO", "ENEB", 
"EDMA", "","EOIP", "ECAP", "EFSO", "", "EBUS", "ESTB", 
"ESRQ", "", "", "", "ETAB"}; 

/* 

* After each GPIB call, the application checks whether 
the call succeeded. 

* If an NI-488.2 call fails, the GPIB driver sets the 
corresponding bit in the global status variable. 

* If the call failed, this procedure prints an error 
message, takes the device offline and exits. 

*/ 
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void GPIBCleanup(int ud, char* ErrorMsg) 

{ 

printf("Error : %s\nibsta = 0x%x iberr = %d 
(%s)\n", ErrorMsg, ibsta, iberr, 
ErrorMnemonic[iberr]); 

if (ud != -1) 

{ 

printf("Cleanup: Taking device offline\n"); 

ibonl(ud, 0); 

  } 

exit(0); 

} 

int start_application( int scope )  

{ 

char write_buffer[100]; 

char read_buffer[100]; 

char app_name[] = "\"TDSDVI\"\n"; 

int status, timer; 

  

  /* Start the TDSDVI application */ 

sprintf(write_buffer, "%s", "Application:activate 
\"DVI Compliance Test Solution\""); 

status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
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if (ibsta & ERR) 

{ 

GPIBCleanup(scope, "Unable to start the 
application"); 

return 0; 

} 

timer = 1; 

while (1)  

{ 

   

/* Check whether application has started */ 

sprintf(write_buffer, "%s", 
"Variable:value? \"application\""); 

status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

status = ibrd(scope, read_buffer, 
sizeof(read_buffer)); 

read_buffer[ibcnt] = '\0'; 

if (strcmp(app_name, read_buffer) == 0)  

{ 

return 1; 

} 

timer++; 

if (timer > 60)  

{ 

return 0; 

} 

Sleep(1000); 

} 

return 1; 
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} 

 

/* Exit the application */ 

int exit_application(int scope)  

{ 

char write_buffer[100]; 

printf("Exit Application ...\n"); 

sprintf(write_buffer, "%s", "Variable:value 
\"application\",\"exit\""); 

ibwrt(scope, write_buffer, strlen(write_buffer)); 

return 1; 

} 

   

/* Run the selected measurement */ 

int run_test (int scope) 

{ 

char write_buffer[100]; 

char read_buffer[100]; 

int timer; 

sprintf(write_buffer, "%s", "Variable:value 
\"sequencerState\",\"Sequencing\""); 

ibwrt(scope, write_buffer, strlen(write_buffer)); 

printf("Executing Test...\n"); 

Sleep(100); 
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/* Wait for application to come to Ready State */ 

timer = 1; 

while (1)  

{ 

timer++; 

if (timer > 90)  

{ 

printf("******Test Time Out 
******\n"); 

return 0; 

} 

sprintf(write_buffer, "%s", 
"Variable:value? \"sequencerState\""); 

ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

ibrd(scope, read_buffer, 99); 

if (ibsta & ERR)  

{ 

GPIBCleanup(scope, "Unable to write to 
device"); 

} 

read_buffer[ibcnt] = '\0'; 

if (strcmp(read_buffer,"\"Ready\"\n") == 0)  

      { 

printf("Test Complete ...\n"); 

return 1;  

} 

Sleep(1000); 

     } 

} 
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void report_generate(int scope,char* reportfilename)  

{ 

char write_buffer[100]; 

char read_buffer[100]; 

int status;  

  

/* Set report file name */ 

sprintf(write_buffer, "Variable:value 
\"reportFileNameChange\",\"%s\"",reportfilename);  

printf("%s",write_buffer);   

status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

if (ibsta & ERR) 

{ 

GPIBCleanup(scope, "Unable to communicate 
with Scope"); 

return; 

} 

Sleep(1000); 

  

   /*Generate the report*/ 

sprintf(write_buffer, "variable:value 
\"reportGenerate\",\"generate\""); 

printf("%s",write_buffer);   

ibwrt(scope, write_buffer, strlen(write_buffer)); 

TDSDVI-DVI Compliance Test Solution           217 



Remote GPIB 
 

if (ibsta & ERR) 

 { 

GPIBCleanup(scope, "Unable to start the 
application"); 

return; 

}  

Sleep(2000); 

   } 

 

void select_measurement(int scope) 

{ 

char write_buffer[100]; 

char read_buffer[100]; 

int status;  

 

/*Select Measurement*/ 

sprintf(write_buffer, "Variable:value 
\"measChanged\",\"Transmitter Eye Diagram\"");  

printf("%s\n",write_buffer);   

status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

if (ibsta & ERR) 

 { 

GPIBCleanup(scope, "Unable to communicate 
with Scope"); 

return; 

 } 

Sleep(1000); 
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/*Configure Data Channel*/ 

sprintf(write_buffer, "Variable:value 
\"dataChannelChange\",\"Ch4\"");  

printf("%s\n",write_buffer);   

status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

if (ibsta & ERR) 

 { 

GPIBCleanup(scope, "Unable to communicate 
with Scope"); 

return; 

 } 

Sleep(1000); 

  

/*Configure Trigger Channel*/ 

sprintf(write_buffer, "Variable:value 
\"triggerChannelChange\",\"Ch4\"");  

printf("%s\n",write_buffer);   

status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

if (ibsta & ERR) 

 { 

GPIBCleanup(scope, "Unable to communicate 
with Scope"); 

   return; 

 } 

Sleep(1000); 
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/*Configure Data Pair*/ 

sprintf(write_buffer, "Variable:value 
\"dataPairChange\",\"RX2\"");  

printf("%s\n",write_buffer);   

status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

if (ibsta & ERR) 

{ 

GPIBCleanup(scope, "Unable to communicate 
with Scope"); 

return; 

} 

Sleep(1000); 

 

/*Setting the number of eye*/ 

sprintf(write_buffer, "Variable:value 
\"numberOfEye\",\"10\"");  

printf("%s\n",write_buffer);   

status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

if (ibsta & ERR) 

{ 

GPIBCleanup(scope, "Unable to communicate 
with Scope"); 

return; 

} 

Sleep(1000); 

} 
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void main() 

{ 

int Dev; 

char write_buffer[100]; 

int status; 

Dev = ibdev (BDINDEX, PRIMARY_ADDR_OF_DMM, 
NO_SECONDARY_ADDR, TIMEOUT, EOTMODE, EOSMODE); 

if (ibsta & ERR) 

{ 

GPIBCleanup(Dev, "Unable to open device"); 

} 

else 

{ 

printf("My device id - %i", Dev); 

} 

Sleep(1000); 

sprintf(write_buffer, "%s", "header off"); 

status = ibwrt(Dev, write_buffer, 
strlen(write_buffer)); 

if (start_application(Dev))  

{ 

printf("\nApplication started....\n"); 

} 

Sleep(10000); 

select_measurement(Dev); 

Sleep(2000);  

run_test(Dev);  

Sleep(4000);  

report_generate(Dev,"fs_sqc"); 
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Sleep(2000);  

exit_application(Dev); 

 

/* leave the device back elegantly */ 

printf("Cleanup: Taking device offline\n"); 

ibonl(Dev, 0); 

} 
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DDWG 

Digital Display Working Group 

DVI 

Digital Visual Interface 

 

Hopen 
 
The maximum horizontal opening between the closest hit points 

 
 
Overshoot (Top and Bottom) 

 
The voltage difference between the minimum high level voltage or the 
maximum low-level voltage after the transition and the normalized 
voltage level (Vswing Low or Vswing High) in the eye mask. 

 
 

Undershoot (Top and Bottom) 

The voltage difference between the minimum high level voltage or the 
maximum low-level voltage after the transition and the normalized 
voltage level (Vswing Low or Vswing High) in the eye mask. 

 
VESA  

 
Video Electronics Standard Association 

Vopen  

The maximum vertical opening between the closest hit points. 

 
Worst Tbit 
 

The minimum distance between two consecutive crossover points. 
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